Go Down

Topic: Trouble loading to board (Read 606 times) previous topic - next topic

AllenPitts

Hello Arduino Forum,

My sketch compiles ok but
the Arduino IDE complains about
a problem loading to board. The
IDE says it is loading to Com 3
but the Windows Device Manager
says the Arduino is on Com 4.

I suspect this is the problem but
I don't know how to change the
com port the Arduino Uno is
using to Com 3. There does
not seem to be an option
in the Device Manager for
changing the port the device
is using.

Research suggests restarting
the IDE with the Arduino connected
to the USB port. I  tried that.
No luck.

How can I change the com port
a device is using in Windows 8?

Thanks.

Allen Pitts, Dallas Texas

johnwasser

In the Arduino IDE you select the serial port in the Tools menu under Port .  Can you select your Arduino there?
Send Bitcoin tips to: 1G2qoGwMRXx8az71DVP1E81jShxtbSh5Hp

AllenPitts

Hello John,

Thanks for the tip.

When the IDE is opened, at the Tools, Port
it shows COM4 with a check mark but there is
no option for changing it.

I did find under File, Preferences find some text that says
"More preferences can be edited directly in the file
C:Users\pitts\AppData\Roaming\Arduino 15 preferences.txt"

So went looking for the AppData folder. Could not find it.
So some research discovered that in Windows 8 one must press the
Windows button + R, type in "explorer", go to the "View"
tab and click "Hidden files" to see the AppData folder.

Following the path in the text above to the preferences.txt
file it was opened. Line numbers 79 and 80 contain this text

serial.port=COM4
serial.port.file=COM4

which was changed to

serial.port=COM3
serial.port.file=COM3

Closed and reopened the IDE.
Still says "Tools, Port, COM4"

Went back and looked at the
File, Preferences dialogue box.
Found more text that says:
"(edit only when Arduino is not running)"

So I unplugged the Arduino and relaunched
the IDE. Still says "Tools, Port, COM4".

Closed the IDE, plugged in the Arduino.
Launched the IDE. Still COM4.

But the ASCII editor being used, TextPad,  sends
a message; "Another application has updated file
C:Users\pitts\AppData\Roaming\Arduino 15 preferences.txt
Reload it?"

So its seems something is changing the preferences.txt.
The compiler stills says it is loading to COM3 and the
IDE says that Arduino is active on COM4.

How can I get them aligned?

Thanks.

Allen Pitts, Dallas Texas






 

Go Up