Go Down

Topic: Mehrere DS18B20 (Read 760 times) previous topic - next topic

larand

Hallo

Ich habe mir einen Logger mit 9 DS18b20 Sensoren zusammengebaut und er scheint eigentlich auch zu funktionieren. Als ich mir die aufgezeichneten Daten ansah, hat sich ein Bild gezeigt, wie wenn zwischendurch mal die Daten von einem Sensor dem nächsten zugeordnet worden wäre. (vgl. Bild )

Hat jemand eine Ahnung woran das liegen könnte?

Die Sensoren sind parallel angeschlossen und ein 4.7kOhm Widerstand von 5V zu Data.


olf2012

Kann meiner Meinung nach nur an deinem Programm liegen :) Das hast du aber nicht vorgestellt.
Die Sensoren liefern ihre Daten immer nur wenn sie mit ihrer Seriennummer angesprochen werden. Falls also was durcheinander kommt, kann es nur an der abfragenden Software liegen

HotSystems

Bitte zeig uns deinen Sketch, dann können wir dir sicher Tipps geben.
Poste den Sketch bitte in Code-Tags, damit wir den besser lesen können.
Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

larand

Nun scheint der Logger so zu funktionieren wie er soll, aber ich kann nicht sagen woran es lag, aber die Temperaturkurven sehen nun gut aus.

kann es sein dass das etwas mit dem folgenden Hinweis beim Kompilieren zu tun hat?

Code: [Select]
"Wenig Arbeitsspeicher verfügbar, es können Stabilitätsprobleme auftreten."

ich glaube der Sketch bringt nun wenig, das es ja nun funktioniert.

Doc_Arduino

Hallo,

was haste denn geändert das es jetzt plötzlich angeblich funktioniert? Wenn der RAM zu klein wird kommt es zu den tollsten Effekten. Wer den Code geheim hält....
Tschau
Doc Arduino '\0'

Messschieber auslesen: http://forum.arduino.cc/index.php?topic=273445
EA-DOGM Display - Demos: http://forum.arduino.cc/index.php?topic=378279

HotSystems

Ok, wenn er geheim ist.

Aber so könnten wir ihn testen und evtl. den Fehler finden.
Speicherprobleme sind immer kritisch, aber ohne Sketch kein Tipp.
Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

Go Up