Go Down

Topic: Genuine Arduino WIFi board returns "no wifi client"... ? (Read 2054 times) previous topic - next topic

chopperaddict

Aug 28, 2016, 02:43 pm Last Edit: Aug 28, 2016, 02:55 pm by chopperaddict
Hmmmmmmm

Not only could I not really get my Ethernet shield to work reliably, but I have now received a boxed, genuine Arduino WiFi shield, but on running any WiFi Sketch, I simply get the message "No WiFi Client"

I have read through this forum and have not really found any info, other than lots of mentions of the WIFI101 library, which I have downloaded and tried, but that gives many errors.

I assume that my board should use the original WIFI.H library ?

Any ideas would be very welcome, I am getting somewhat disenchanted with these shields so far.  2 out of 2 failures ain't very good.

AndreaRichetta

Hi
are you referring to this product?
https://www.arduino.cc/en/Main/ArduinoWiFiShield101

can you detail more this "but that gives many errors"
which board is under the shield?

have you tried with latest 1.6.11 IDE + WiFi101 library?



chopperaddict

Hi
Sorry if the info I  gave was a little lacking.

The board I have is NOT the one you list, but it came in a genuine Arduijno box from Italy, and has a sticker on the top surface that says :

NEW IDE
Ardiuno.org

I  do not  know what that means, but as usual there was no documentation worth having in the package other than the much folded up Arduino advertising slip.

It is running on a standard Uno ( I have tried 3 different Uno boards) When code is loaded, the boards LED's flicker, if I press the reset on the shield I get a brief RX flash, and after quite a delay, another "WiFi shield not present" in the monitor window.

The same Uno boards have worked with an Ethernet Shield from the same source.

I am using the 1.7.10 Arduino programming interface, so the very latest I would guess, as it is what is  on the arduino.cc site right now. ?

I tried loading the "wifi101.h" file as well, but that gave errors in one of the original .cpp files ?

I do not know what else I can tell you, I have a working WiFi router in my BT hub 5 and those settings for user/password are entered into the example WiFiChatServer sketch.

The line in the sketch to connect the server is set to port 23 - (the standard telnet port), but almost the next line :

if (WiFi.status() == WL_NO_SHIELD) {
    Serial.println("WiFi shield not present");

Is what I get - every time.

Help please ?

CrossRoads

This forum is for Arduino.cc, latest IDE is 1.6.11
https://www.arduino.cc/en/Main/Software

.org is the manufacturing ex-partner who split off on his own. Try their forum for 1.7.10 help.
Designing & building electrical circuits for over 25 years.  Screw Shield for Mega/Due/Uno,  Bobuino with ATMega1284P, & other '328P & '1284P creations & offerings at  my website.

Go Up