Go Down

Topic: Can't Download ESP8266 Board Package (Read 40200 times) previous topic - next topic


This problem with the libraries is an ongoing mess.  Sometimes it works, sometimes it doesn't.  When it does not the Arduino IDE does not list the ESP8266 boards.   Sometimes it works on one computer and fails on another.  Sometimes it fails on both using the Arduino IDE.   I also have the Visual Micro installed for Visual Studio 2017 and when the Arduino IDE, fails, I can jump onto Visual Micro and continue working.  (MOST of the time).  I will post a different problem I encountered last weekend with the libaries becoming corrupted.

After digging on the Internet, I finally found a page that described how to manually install the boards and libraries from GITHUB without using the Arduino IDE Preferences and boards manager.


For now, that is the solution I am using and it seems to be working OK.


@ashok99 ..Bro my problem is solved. Thank you.But could u tell me why you have deleted that .tmp file..


 :) try with link http://arduino.esp8266.com/versions/2.5.0-beta2/package_esp8266com_index.json


:) try with link http://arduino.esp8266.com/versions/2.5.0-beta2/package_esp8266com_index.json
The problem with that URL only works for the 2.5.0-beta2 release. If you use that URL, you will not get notifications for future updates or be able to update to newer updates than 2.5.0-beta2. I have seen the use of these URLs cause problems for people several times in the past where it caused people to be using a very outdated version while thinking that was the latest one available.

If there is a situation where the standard URL simply can't be made to work and the version-specific URL will work, then I guess it's a reasonable choice. However, I can't imagine how that would ever occur. Certainly, if you're going to recommend the use of one of these URLs, you should also warn people of the consequences and recommend that they regularly check for new versions. This is especially important with this release since it's a beta version and thus is more likely to have bugs. These beta releases are not really intended for general use. They should only be used by people who are interested in helping the development work by doing beta testing and reporting any bugs they find.


I have solved this in a bit of a tedious operation,
opening "%appdata%\local\arduino15\staging\packages\" and for each error downloading given in the arduino IDE, i downloaded the ZIP file manually, and copy to the above directory, after the fifth zip was copied. all was fine.

I know this is not a sustainable solution. but for the time being it solved my problem


Thanks for sharing your solution jaafar_nasrallah. I'm sure that will be helpful to anyone else having this problem.


i m with the same problem... how you resolved ?
thank you


i m with the same problem... how you resolved ?
thank you
It looks like SandroM has a dedicated thread for the issue, which would probably be the most appropriate place for any further discussion of their particular problem to avoid wasting time from duplicate efforts:


This workaround worked for me. Though the URL was returning expected JSON it was returning error "Error downloading http://arduino.esp8266.com/stable/package_esp8266com_index.json" in IDE. I tried following and now I'm able to resolve this issue.

1. Open preferences.txt from C:\Users\AppData\Local\Arduino15 ( this path may vary depending on your
OS) and remove value for "boardsmanager.additional.urls"
2. Delete all .tmp files from this folder (C:\Users\AppData\Local\Arduino15)
3. Copy & paste URL in File->preferences
4. Goto Board-> Manager board... now you dont see any error and ESP8266 should be there in the list

thanks Sir,this really helped!


Any help appreciated. Thanks.

I have used Gsender.h & Gsender.ccp to send email by ESP8266,It works well.
But when the Sketch uses more than 84% the ESP reset (wdt reset)

Would you please help me


@MajidAtaeiChatroodi please don't hijack threads. Your problem is completely different than the subject of this thread. You have a dedicated thread to discuss your problem:


Go Up