Go Down

Topic: Mac OSX (10.4.11) and Diecimila connection help (Read 8312 times) previous topic - next topic



And I have no idea what any of it is?


I have had much the same problem with MBP(intel), OSX 10.4. and Anduino Decimalia.

I have tried pretty much everything (that I know of) and with no luck. However I am able to get the upload to the Anduino, but when I comes to serial communication it's been a dead end so far.
I have been trying to get Serial Server to work, but it seems its impossible with the RXTX driver supplied with the Andiono-0009. If I update the driver to a newer one, at least Serial Server will start, but is unable to show me what is sent from the serial port, and the Anduino IDE will not upload or show me serial data. In spite of in-depth research I have not been able to find a working alternative to Serial Server. My guess is that it's a problem with the RXTX driver..  

I was, like you, hoping that I could interface with flash, but I doesn't seem possible on mac.. crap?

New tips are very welcome!

/ Esben


wurx: check out /System/Library/Java/Extensions and /Library/Java/Extensions and (in your home directory) ~/Library/Java/Extensions (if it exists).  What do you see?  We're looking for comm.jar or jcl.jar or RXTX-something or anything else that might be a serial communication library.

Esben: which serial server are you talking about?


I have pretty much the same problems as described above, but my ports list is not greyed out. In Arduino10 there are two ports listed, dev/tty.modem and dev/cu.modem but neither connects to my Diecimila. The java files you mentioned are not to be found on my mac, iBook G3



bjornw: did you install the FTDI drivers?  If you open the Terminal (w/ the Arduino connected) and type:

ls /dev/tty.*

What do you see?  Does the board work on any other computers?  Which version of Mac OS X are you running?


A bit embarrasing, the B-connector of the USB cable wan't snuggly fit in the socket...
I guess I didn't want to break anything on my new Diecimila, so I fitted it quite loosely, and when it started blinking I assumed the connection was ok. Well, now it works perfectly well. Thanks Mellis!

Go Up