Go Down

Topic: need help arduino mega 2560 (Read 453 times) previous topic - next topic

jose_bouce

i have this problem after burn bootoader
pleas help
  led stay blinking 2 times   
1- i cant upload any code (no tx rx blink)

2- i have this error messeg

avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer
Une erreur est survenue lors du transfert du croquis

Budvar10

Check the fundamental thing first, whether the port exists on the PC. No tx blink means that no call arrives to Arduino.
The L should blink 3 times fast at connection to PC or reset, it means also at uploading start. If no then try to upload the bootloader again. Make sure that used bootloader is correct.
Arduino clone with ATmega1284P   http://forum.arduino.cc/index.php?topic=277260.0

jose_bouce

all is good port and  bootloader  alll is good but  the arduino  is stay not working

Budvar10

Not all is good if the Arduino is not working. ;)
Tx should blink at least once as the upload starts.
Arduino clone with ATmega1284P   http://forum.arduino.cc/index.php?topic=277260.0

BobbyCompos


jose_bouce

i think is a hardwere probleme  if i can upload code without using usb port with an other  arduino uno ??

Budvar10

#6
Dec 15, 2017, 07:39 am Last Edit: Dec 15, 2017, 07:43 am by Budvar10
With other Arduino, via ISP or via RxTx? Post more detailed description.
If via ISP then the bootloader can be a problem. If via rx,tx then you would focus to on-board transceiver, i.e. ATmega16U2, its FW or the HW around it.
Arduino clone with ATmega1284P   http://forum.arduino.cc/index.php?topic=277260.0

Go Up