Go Down

Topic: JTAGICE3 com port (Read 387 times) previous topic - next topic

mOskit

Hi Guys

I`m having issue with JTAGICE3 programmer. i can see its supported in the IDE but the comport is not shown.
Any suggestions on that one?

thanks

pert

I don't have any experience iwth the JTAGICE3 but it's likely a pure USB device and thus wouldn't have a COM port. What makes you think a COM port should be shown?

mOskit

So basically you cannot upload any code through ide. Also in visual studio, the only way to see what port is used is to go to programming mode and press the button to initiate and then I can see what port has been selected. I'm sure that is not as it should be.
Further more I can burn bootloader through visual studio but not through the Arduino IDE.


pert

So basically you cannot upload any code through ide.
To upload via the JTAGICE3 you need to do this:
  • Tools > Programmer > Atmel JTAGICE3 (ISP mode)
  • Sketch > Upload Using Programmer

Note that when you upload using programmer you erase the bootloader and thus will no longer be able to do serial uploads via USB until you have done a Tools > Burn Bootloader on the board again.

Further more I can burn bootloader through visual studio but not through the Arduino IDE.
Please do this:
  • File > Preferences > Show verbose output during: > compilation (uncheck) > upload (check) > OK
  • Tools > Burn Bootloader
  • After the process fails you'll see a button on the right side of the orange bar "Copy error messages". Click that button.
  • Paste the error messages in a reply here USING CODE TAGS (</> button on the toolbar).

Go Up