Go Down

Topic: El Capitan - Arduino IDE serial port problems (Read 82617 times) previous topic - next topic

braines

I was fighting with this on a new Ada fruit Huzzah ESP8266 board. I installed their USB driver, or thought i had, since its a Kext I needed to do the restart option-r csrutil -disable thing and then reinstall it.

For a while now I had also had some issues with my Arduino Mega only being recognized on one of my two physical USB ports and just been too lazy to investigate since it was easier just to plug in to the 'back' port not the 'front'.
As part of fussing with the Huzzah driver I noticed and UNINSTALLED (aka deleted) an OLD FTDI USB Kext I must have put in before upgrading to El Capitan.   

That seemed to simultaneously fix both my front USB port with the Arduino Mega and allow the Huzzah to work on either port!  and here I thought driver/extension incompatibility issues were dead :)  now... to do carve out some time to actually make something before someone upgrades something!

posting in the hope that my random experience helps someone else struggling with this issue.

mark mccarthy

As part of fussing with the Huzzah driver I noticed and UNINSTALLED (aka deleted) an OLD FTDI USB Kext I must have put in before upgrading to El Capitan.   
how did you go about doing this? I suspect I have the same situation.

thanks
mark.

sm_mirhoseini

Hi,
How could I add usbport1411 to my mac, at the moment it is working with wchusb1420 which is not compatible with "Arduino Leonardo".
Thank you

heaven_rover

My arduino have been worked OK under EI Capitan (don't ask me how)
But two days ago I moved to brand new Sierra Mac OS and got system halting during inserted USB cable ((
Two days of attempting different drivers haven't gave any result.

Finally I got the cure and now it works good (no halts or hang and Arduino SDK 1.6.3 sees port /dev/tty.wchusbserial1420)

(most importan I think were the command sudo rm -rf /System/Library/Extensions/usb.kext
as it is despite any reasons (i.e. I hadn't see this "usb.kext" but possibly it was hidden)

aroramayank2002

Worked for me:

 Reboot and press CMD+R immediately after hearing the startup sound to boot to Recovery Mode
   Open Terminal
   Execute the following command: csrutil enable --without kext
   Reboot

Install the following driver:

https://github.com/Makeblock-official/Makeblock-USB-Driver/blob/master/CH34x_Install.zip

AlanGP

I have the same problem with Arduino IDE 1.8.0 (new this week) and a Node MCU1.0. No idea why had to use my Win 7 PC which is a nonsense.

Tendali

Hi, I tried everyone of these solutions, but none of them worked. But I found that there is a sure way to get rid of this problem. Dual-boot macOS/OS X [insert your os name here] and OS X Yosemite. And since the Yosemite installer is still up on the app store,
you can just download it and make a bootable flash drive, then partition your drive to accommodate the new OS and just restart while holding Alt and then boot of the USB drive and then hit re-install or install OS X.
But this is kind of a last thing I would try since it's not very fun to switch between OSes when you want to use arduino, but hey, it works.

Go Up