Go Down

Topic: USBtinyISP and issues... (Read 1 time) previous topic - next topic

fifteen54

I have an Arduino Uno as well as several freeduino boards and some EMSL Atmegaxx8 target boards. I was trying to take the leap from Arduino to AVR programming, and I decided to start flashing sketches directly to my Arduino. I edited the preferences.txt file to use the usbtinyisp and followed directions and when I try to upload a sketch I the get error:

Quote
USB write error: expected 128, got -1
avrdude: verification error, first mismatch at byte 0x00ef
         0x92 != 0xa9
avrdude: verification error; content mismatch


After I searched for solutions for hours and decided I wasn't ready for the head ache of setting up development outside of Arduino yet and tried to burn the bootloader back I got the same error.

Just to be sure that It wasn't my Uno I tried my other barebones card and the same issues arises...

Incidentally AVRDUDE registers fine and will erase the chips, I just dont have any .hex files to try and upload and as said before developing outside of the Arduino IDE seems nightmarish...

mrtaylor

Quote
I just dont have any .hex files

Hold the shift key down and verify (not upload) a sketch and it shows where is hex file is. At least in Ubuntu.

fifteen54

Thanks I found where Arduino stores compiled code however, I still get the same error when I use AVRDUDE directly...

mrtaylor

What operation system are you running?


mellis

I've seen errors like this before with the USBtiny but never figured out what caused them.  I would ask on the adafruit forum, they're usually great about providing support.

Go Up