Go Down

Topic: Control de luces de Acuario (Read 5440 times) previous topic - next topic

Perdido

Es un step down regulable a 12V o 9V incluso, la duda que tengo es por la intensidad.... creo que solo te permite bajar el voltaje de ahí lo de poner el LM... esperando rebajar con el los 4.4A a 1A.... Por motivos que desconozco la mayoría de step down que hay solo trabajan a 40V como máximo, y algunos si que permiten rebajar la intensidad, pero a 48V ya no he encontrado ninguno.

En cuanto a poner un cargador a la placa tengo otra duda... no seria necesario poner un octoacoplador para separar los dos circuitos?, si lo engancho al driver, estaría mezclando las dos voltajes? pasaría algo al hacerlo?? o al conectarlo únicamente al PWM ya no seria necesario???

_jose_

#16
Mar 30, 2018, 06:52 pm Last Edit: Mar 30, 2018, 06:56 pm by _jose_
No hay problema con la intensidad en el stepdown ,el arduino consumira el amperaje que necesite.Si usas un cargador de mobil tendras que conectar los negativos del cargador y de la fuente ,ya que vas a usar los 5v de la salida analogica del arduino para dimear los drivers que alimentas con la fuente. Ojo ,con el cargador de mobil no alimentas por pin vin y gnd ,si no por el mismo conector con el que usas para el usb del ordenador.

Perdido

Entonces... el arduino seria capaz de absorber el excedente de 4A?... no lo recalentaría??

Buscare un transformador que alguno tendré por ahí seguro, pero por alguna razón me parece algo mejor la solución del step, me da la sensación de ser como menos engorroso tener solo una conexión de corriente que dos, aunque en realidad de un poco igual.

_jose_

#18
Mar 30, 2018, 07:48 pm Last Edit: Mar 30, 2018, 07:49 pm by _jose_
no hay excedente ,imaginate una fuente de pc de 700w ,que puedes usar tanto para un pc gamer que puede consumir 350w o mas ,solo en procesador y grafica, como para uno de ofimatica con un procesador de 45w y grafica integrada ...¿a donde va la diferencia? simplemente la fuente modula la salida segun la demanda.

Perdido

#19
Apr 01, 2018, 04:58 pm Last Edit: Apr 01, 2018, 05:19 pm by Perdido
Muchas gracias por la ayuda!

Al final me decanto por el step down, los transformadores viejos que tengo por casa son o de 5V nada mas o de menos mA.

Así que nada ahí pongo el esquema, añadiendo ademas las conexiones para una pantalla ILI9225 3.3V (creo que me precipite al comprar este componente ya que no trabaja a 5V, no me di cuenta, pero tiene solución) por si a alguien le sirve.


Perdido

#20
Oct 21, 2018, 02:12 pm Last Edit: Oct 21, 2018, 02:15 pm by Perdido
Buenas otra vez,

he continuado avanzando en este proyecto... y cuando creía que ya lo tenia todo montando... me ha surgido un fallo que no entiendo por que ocurre y no se me ocurre como resolver... a ver si me podéis decir que estoy haciendo mal.

Al diseño que ya tenia, he añadido 6 sensores de temperatura, uno para cada canal de color, otro para la temperatura del agua y 4 ventiladores de 5v para el disipador.

El caso es que al ir a conectar el pin de 5V que los conecta, la placa arduino parece que no termina de arrancar, le llega corriente por que se encienden los leds pero con escasa potencia.. de forma atenuada... si quito el pin de 5v funciona perfectamente... También pasa con el led que trae el step down, que alimenta al arduino, curiosamente, cuando falla se queda en un estado rojo/verde. Es como si hubiera algún elemento que esta haciendo excesiva resistencia.

Los ventiladores los he puesto en dos series, con un diodo de protección por cada una de ellas y un transistor 2n2222, lo único que se me ocurre es que no sean el transistor adecuado para esos 20v.

He comprobado la continuidad de todos los elementos y parece que esta todo correcto. Asi que no se que puede estar pasando. Adjunto el gráfico actualizado y un par de fotos del montaje por si ayudan algo.






jordi3sk97

#21
Oct 22, 2018, 02:35 am Last Edit: Oct 22, 2018, 02:37 am by jordi3sk97
He estado un rato leyendo tus mensajes, no termino de entender lo que quieres hacer ni se porque no obtienes lo que quieres.....

Pero si que he encontrado algunas discrepancias entre lo que dices y lo que dibujas, veo que te has esforzado en mostrarlo pero en algún momento has perdido la concentración.

IMHO Te recomiendo que hagas las cosas paso a paso. conectando la electrónica de uno en uno, por ejemplo:

1 - Conectar las alimentaciones uniendo los negativos y comprobando tensiones.
2 - Conectar ventiladores y dar positivo a la R de 330 Ohms y comprobar que los ventiladores funcionan.
3 - Conectar los leds y Drivers y seguir comprobando tensiones.(No conectar los driver sin los leds)
4 - Conectar, ahora si, el Arduino , y con un pequeño programa comprobar que activa y desactiva los ventiladores.
5 - Ampliar el programa para comprobar la modulación de los led.
6 - Conectar el RTC + programa que compruebe que funciona bien + lo anterior
7 - El lector de SD +  programa .....
8 - Uno de los sensores + programa .....
9 - El resto de los sensores........
10 - Por fin, tu programa, sabiendo que tienes el hardware  controlado.

../..
Los ventiladores los he puesto en dos series, con un diodo de protección por cada una de ellas
Que es dos series ? En el esquema los ventiladores están en paralelo.
Porqué pones diodos ? y porqué 4 ? No son ventiladores Brushless ?
El símbolo del diodo no es ese.

../..
El caso es que al ir a conectar el pin de 5V que los conecta,
"Los conecta" el que ? los ventiladores ? no van a 20V ?  De que pin hablas ?

Mirando el circuito
La resistencia de 4.7K no es PullDown, es PullUp

Las resistencias de 10K tal y como están no sirven para nada bueno, si han de ser PullDown (que yo no digo que lo hayan de ser) tendrían que estar conectadas cada una de ellas entre negativo y cada una de las entradas de los drivers, (cables azules).

Los negativos GND de "potencia", únelos fuera del Arduino, el que más duele a los ojos es el de los ventiladores. Puedes unir los negativos de las salidas de los StepDown antes de llegar al Arduino

Asegúrate que en los StepDown, los negativos de entrada y salida sean los mismos, es decir, que la pista de la pcb vaya directa. Si no fuera así no se podrían unir los negativos de la fuente de 48V con los de las salidas de los StepDown y todo tu sistema seria un fracaso.

Convierte tu puzzle en partes pequeñas y lo conseguirás, Suerte.

PD, (No seria conveniente cambiar el titulo del hilo ?)

Perdido

#22
Oct 22, 2018, 09:41 pm Last Edit: Oct 22, 2018, 09:43 pm by Perdido
Ante todo muchas gracias por la respuesta!

Perdona si no me he explicado bien, a veces tiendo a correr :smiley-roll-blue:  intentare hacerlo mejor ahora:

El objetivo es montar una iluminación para un acuario, con 5 canales de luz con dimeado independiente para cada uno de esos canales, medidor de temperatura del agua, y mas funciones que espero poder ir haciendo según aprenda algo mas...

El esquema que puse efectivamente tenia algunos detalles que no eran exactos (por no redibujarlo), así que ahí pongo uno que si que lo es. Respecto a las "series" (no se si esta bien dicho así) de ventiladores, los dividí en 2 para rebajar el voltaje de los dos transistores por que no estaba seguro si aguantarían 20V. Me pareció que seria mejor dos grupos de 10V.

El pin de 5V creo que me refería al de los sensores de temperatura.



Cuando he leído tu mensaje he caído en la cuenta de una cosa... había probado todas las partes por separado en la Protoboard ... todo funcionaba bien y ya daba por supuesto que por lo menos la parte de los leds estaba perfectamente ya que al encender se iluminaban sin problema... pero no había probado si se apagaban y encendían o si funcionaba el dimmer en el proyecto final!  :-[  

Lo he probado ahora y apagar y encender si lo hace.. pero el dimmer... nada de nada.. solo apaga y enciende... así que como has comentado, deben de ser las resistencias que están puestas como pull-up...  parece que has acertado en eso!, supongo que creía cuando lo diseñe que el modulo de los drivers ya conecta el negativo a la placa.. Primer error por lo que se ve...

En cuanto a montarlo por partes... tienes toda la razón, no lo había hecho por que tengo de desoldar unas cuantas cosas... pero creo que no tengo mas remedio.

Tengo también mis sospechas que los GND no estén correctos, no entiendo muy bien lo que me comentas, por un lado dices que puedo unirlos los steps down antes de conectarlos a la placa... por donde exactamente? los dos por la conexión out y luego de esta a al pin GND arduino?, no se que diferencia habría ya que tal y como esta ahora.

Y por el otro hablas de comprobar los negativos de salida y entrada... ¿no deberían ser 0V al ser GND? tampoco se a que te refieres con la pista pcb y directa.... ¿con que?

Menuda parrafada que he soltado ;P

PD: he intentado cambiar el titulo del post... solo me cambia el del ultimo mensaje, no he sido capaz :smiley-confuse:




jordi3sk97


Tengo también mis sospechas que los GND no estén correctos, no entiendo muy bien lo que me comentas, por un lado dices que puedo unirlos los steps down antes de conectarlos a la placa... por donde exactamente? los dos por la conexión out y luego de esta a al pin GND arduino?, no se que diferencia habría ya que tal y como esta ahora.

Y por el otro hablas de comprobar los negativos de salida y entrada... ¿no deberían ser 0V al ser GND? tampoco se a que te refieres con la pista pcb y directa.... ¿con que?

Intentare explicarme mejor.

Los dos puntos anteriores se refieren a lo mismo, al (-) o GND.

Tienes 3 (-) de tres  fuentes de tensión, uno de la fuente de 48V y dos de los StepDown, 
En el primer dibujo cada uno de los tres lo conectabas a un terminal (-) de la placa Arduino.
Esto no es bueno, conecta los tres (-) juntos fuera de la placa y luego conecta un solo (-) al Arduino.

Ahora bien, esta mezcla de tres fuentes de tensión que haces, (y que a mi no me gusta nada) solo funcionara si el (-) de la fuente de 48V es exactamente el (-) de las salidas de los StepDown.

Para verlo tienes que coger los StepDown y mirar las pistas, el (-) de la entrada tiene que ir directo al (-) de la salida .
Dicho de otro modo, los electrones que salen del (-) de la fuente de 48V y que llegan al (-) de la entrada del StepDown y siguen hasta el (-) de la salida del StepDown lo tienen que hacer pasando solo por cobre, sin nada de electrónica en su camino. La electrónica ha de quedar en los (+). 
Lo siento pero no te lo se explicar mejor.

Perdido

Creo que entiendo lo que dices, te refieres a los propios componentes, los steps downs, que tengan unión directa en el negativo sin pasar por el ningún componente entre sus dos polos.

Uno tengo claro que si que es directo, parece que por detrás hay un hilo que no pasa por nada mas, el otro no se ve nada por debajo... así que he probado la continuidad entre los dos y si que da... así que supongo que no hay ningún componente entre medias.

Ahora me has dejado preocupado con aquello de que no te gusta la unión de las tres fuentes de tensión.... como he comentado soy novato en estos temas y esa fue la solución que encontré al tema de la fuente de alimentación.

¿que otra/s solución/es podría haber para este caso que fuera mas correcta? ¿por que esta no es buena?

Perdido

#25
Nov 04, 2018, 06:20 pm Last Edit: Jan 03, 2019, 10:09 pm by surbyte
He estado probando diferentes cosas y he encontrado lo siguiente:

1. El dimeado no funciona con las resistencias pull-down o pull-up (pasa lo mismo con las dos configuraciones). Eliminándolas ha funciona la iluminación con el dimer sin problema.

2. El error que preguntaba que provocaba el apagado de la placa arduino... había puesto mal el gnd y el 5v... no se que paso pero me lié:smiley-roll-sweat: , así que ya no se produce un corto, pero surgió otro problema, me seguían sin dar lectura los sensonres de temperatura... enredando mas he visto que solo podía conectar 3 a un pin... peerroo... rebajando la resistencia a 4k en vez de 4,7k si que funcionan 6 sensores.

3. haciendo pruebas con los ventiladores... no se que hice... pero creo que me los he llevado por delante.... los 4 :smiley-cry: supongo que habrá sido por meterle mas intensidad de corriente... El miedo que tengo ahora es comprar otros nuevos y volver a estropearlos... ¿como puedo probar ese circuito sin riesgo de freírlos?

Tengo pensado unir las masas gnd como me habéis comentado... el tema es que no se como puedo rebajar esa intensidad de la fuente de alimentación ¿alguna idea? o pensáis que puede ser otra cosa?


surbyte

Nada consume mas de la cuenta.
Uno o 4 ventiladores que consume X mA seguirán consumiendo 4*X mA si estan conectados en paralelo.
De modo que usa una fuente de 1000A y ellos seguirán consumiendo lo que requieran.

Lo único que quema un ventilador de 12V por dar un dato es aplicarle mayor tensión lo que obliga a que circule mayor corriente.

Perdido

oks gracias,

Supongo que siendo así, lo que habrá pasado al toquetear, es que cuando les di corriente, no estarían haciendo contacto 2 ventiladores y los otros dos si... recibiendo los 20V esos 2 en vez de los 10 que debían entrar para cada bloque...y al seguir toqueteando me he llevado por delante los otros 2.

Que rabia! :smiley-confuse:

Existe alguna forma de poder recuperar esos ventiladores? o me olvido y toca comprar nuevos?

surbyte

Pero como 2 ventiladores reciben 20 en lugar de 10, como los conectaste? En serie?

Los ventiladores tienen una especificación como todo. Se alimentan con determinada tensión digamos 12V y se conectan en paralelo.

Perdido

Los ventiladores estaban conectados como en el gráfico... en paralelo 2 y 2 en serie... y ahora que lo dices... al estar en paralelo... el step down tenia que dar 10V no 20V.... he ahí la gran metedura de pata... no?

Go Up