Go Down

Topic: Problem uploading sketch to Nexus 4WD 10009 robot kit (Read 406 times) previous topic - next topic

Zulkhuu

Hi

I'm working with this robot kit:
http://www.nexusrobot.com/product/4wd-100mm-mecanum-wheel-learning-arduino-kit10009.html
Its main board is:
https://www.vstone.co.jp/robotshop/index.php?main_page=product_info&products_id=3829
User manual:
https://www.robotshop.com/media/files/pdf2/user_manual.pdf

I tried to upload blink example with no success.
I tried both Online IDE and Desktop IDE in Windows and Ubuntu 16.04.

I got following error every time:

Sketch uses 928 bytes (3%) of program storage space. Maximum is 30720 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00
Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

I tried setting controller as Atmega328 and tried setting board as Nano, Duemilanove and Diecimila.
When I run Tools->Get Board Info, I got following:

BN: Unknown board
VID: 0403
PID: 6001
SN: Upload any sketch to obtain it

Does anyone have experience working with this kit?
Does it come with proper bootloader?

PaulS

Quote
Can you tell me what is the problem here?
Sure thing. You failed to follow these instructions.
Quote
Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.
If you HAD, you'd know where to post your thread - it is NOT a Robotics issue - AND you'd know to answer a boat-load of questions without needing to be asked.
The art of getting good answers lies in asking good questions.

Go Up