Go Down

Topic: Apple II smartport emulator, sketch works only when usb powered.  (Read 675 times) previous topic - next topic


Hi, i have ported an Apple II smartport floppy disk emulator to Arduino, using an SD card adapter and connecting it to the IDC 19-pin of an Apple IIc and IIgs.
It works fine but... only when connected with USB, attached to the PC or via a phone charger

I'm making test since weeks, but i can't stand what's the problem.
I have a good 5v and 12v from Apple, so i tried powering Arduino via VIN pin or 5V pin but... no luck.
The sketch starts, but the communication with the Apple hangs when usb cable disconnecting.
The smartport protocol is time critical, so i can't investigate too much within the code, but it seems all wery strange!

Other info... i tried in removing the autoreset, used both an Arduino UNO and a few of NANO... nothing.

I connected 5V or 3.3V line to usb diode, but nothing change.

My bigger doubt is... now i am testing with some board with 340ch serial IC, since i burned my original one some weeks ago while testing connection...

Any idea in what else try? thank you in advance for any help!


Solved myself, reading other post about powering issue: i didn't connect togheter the SDCard and Apple II grounds!
i thought that all arduino's gnd was wired togheter,  so i just grounded each one to arduino, but it's not the same thingh, as seems..
Hope this may be a lesson for someone else... as for me. Thank you everybody

Go Up