Go Down

Topic: This is a disappointment (Read 454 times) previous topic - next topic

StaffanEk

I purchases a Yun and considering the disappointment so far it might be a flawed product.

First. Feeding 5V to Vin does not work at all, completely dead. Well, there goes my plan to use it in my robot project. It will have to be connected to USB power the rest of it's life. I maybe would have sent back the device at this time but I wanted to gain some experience with it. It was also discovered after some days filled with lots of other frustration, and a month after purchase. I am not sure about the return policy.

I manage to configure and connect it to my network. I connect it to the IDE and sometimes manage to download sketches. It occasionally works and sometimes not at all. I know the rule "Tell me what what the problem is or we can't help" but I am simply unable to describe a completely erratic behavior. I try to do according to some of the examples and tutorials but the basic rule is: "It never works the first time". A normal day with my Yun is start up the device, get the blue led and it to be visible in the network, start IDE on my computer and do something else for half an hour and then maybe, maybe it will show up with it's IP address. I could choose to connect with USB cable but I really think that connecting with wifi should work, it is so to say what it is built for and what I pay extra for.

Anyway, there is linux on the device I have been told. I am not very experienced but I know some things about how to write commands from a terminal window and the arduino home page writes a little about how to do. So I start terminal and write ssh root@myipadress. Nothing happens, connection times out. So give a few other tries without success. Then write ssh root@deivename.local more by chance and it connects showing a nice Open WRT logo (Later it worked to type the IP address, no surprise since the rule "It never works the first time" applies here also). I am told the the command "ls" shows files and folder. I type it and nothing. Empty. Should it be like that? I thought there was a file system and "things" like python and other stuff. Or am I supposed to create something of my own.

So I suspect that I need an update of Open WRT. I download to an SD card and try to do according to the tutorial, neither by the web panel (the reset button never shows up) or writing "run-sysupgrade /mnt/sda1/openwrt-ar71xx-generic-yun-squashfs-sysupgrade.bin" in the terminal. (Also here, after writing this I did another try and the file and reset button showed up in the web panel, the rule still applies)

So here I am, 50 € poorer and quite a lot more frustrated than before I bought the Yun. So go ahead and tell me I am too stupid for this device.

Arkolis

#1
Sep 25, 2018, 11:37 pm Last Edit: Sep 25, 2018, 11:50 pm by Arkolis
Did you run through the startup sketch that is installed on the yun?
If you already sent a sketch to the yun, you probably wiped the setup sketch off. You can reload the setup sketch from File > Examples > Bridge > Yun First Config
Once its pushed open the Serial Monitor and you will see the setup.

Also I remember reading somewhere that you have to be careful with the 5v pin as there is no voltage control for that pin. (Someone correct me if I am wrong) Also you have to have the ground wired in (if you didn't already).

I am actually using my Yun with Adafruits powerboost 500 (battery shield) that manages the voltage to the 5v pin and ground for me.

ballscrewbob

Which revision YUN ?

The write up IIRC states that you are better off doing upgrades etc via Ethernet or USB for reliability reason I would think.

Yes it is a beast of a board but one you get over the initial hurdles it is surprisingly easy to use.

Don't rush at this type of board trying anything and everything !
Take your time and if you see any console messages copy then into notepad and paste them back here but use CODE TAGS ( </> ) if its any type of error.

Problems with IP's can be from multiple sources.
If you can reserve an IP in your router for it then do so as I found that more use and easier to play with.

Ended up sending FIRSTCONFIG sketch up to it about 4 times before I fully understood what I was doing (apart from jumping in blind)

Only change a setting if you FULLY UNDERSTAND it so not guess.

It too me at least two tries to do the upgrade for the firmware the first time as I found one of the BIN file names was a little different to the tutorial and until I got that nailed down I kept hitting a brick wall so also double check each and every command before you commit.

As Arkolis said check the specs for the VIN as that rings a bell with me too but I cant remember where I saw that.

There are a few posts about doing the firmware update so you may also want to read those too.

RTM etc.

It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

Go Up