Go Down

Topic: Computador não reconhece a placa de arduino (Read 21176 times) previous topic - next topic

mvidigal

Olá pessoal,

estou com alguns problemas e gostaria de ajuda.

Ontem comprei uma placa arduino leonardo, pois desejo começar a aprender sobre arduino. Comecei fazendo alguns programinhas bobos, como os exemplos propostos pelo próprio desenvolvedor (blink, etc...), e de repente a placa deixou de ser reconhecida pelo computador. Agora, quando conecto-a ao computador pelo USB ou por qualquer outra fonte de energia, o led verde "on" acende e o laranja do led também, mas nada mais acontece. Também não me lembro exatamente qual foi o último upload que fiz para a placa.

Já troquei de computador e de portas, mas sempre acontece a mesma coisa, não sei mais o que fazer. Já até troquei de cabo USB, e nada. Também não encontrei ninguém que tivesse relatado o mesmo problema que eu na internet.

Meu computador possui dualboot com Ubuntu 12.04 e Windows 7, e em ambos OS acontece a mesma coisa. O arduino IDE não reconhece nada em nenhuma porta em nenhum sistema operacional e também não consigo enxergar a placa pelo painel de controle no windows.

Uma última observação: quando a placa está conectada ao computador, em qualquer sistema operacional, e eu aperto o botão de reset, o computador a enxerga por alguns segundos e depois some. Então eu sei que a placa não está com nenhum problema.

Alguém me ajuda?
Obrigado galera!

bubulindo

Tenho a sensacão que o último programa que enviaste para lá está a fazer algo que não deve.

O manual do fabricante diz isto:

Quote
These differences affect the way you use the physical reset button to perform an upload if the auto-reset isn't working. Press and hold the reset button on the Leonardo or Micro, then hit the upload button in the Arduino software. Only release the reset button after you see the message "Uploading..." appear in the software's status bar. When you do so, the bootloader will start, creating a new virtual (CDC) serial port on the computer. The software will see that port appear and perform the upload using it. Again, this is only necessary if the normal upload process (i.e. just pressing the uploading button) doesn't work. (Note that the auto-reset is initiated when the computer opens the serial port at 1200 baud and then closes it; this won't work if something interferes with the board's USB communication - e.g. disabling interrupts.)


http://arduino.cc/en/Guide/ArduinoLeonardoMicro?from=Guide.ArduinoLeonardo

Já experimentaste?

This... is a hobby.

mvidigal

Reparei que ao conectar a placa ao computador e apertar o botão de reset, o computador enxergava a placa por breves segundos. Assim, com a placa conectada, apertei o botão de reset e rapidamente fiz upload do programa blink. Resolveu!

Obrigado pela ajuda!!

KORSH

Muito bom isso tenho um 2009 aqui que parou ontem de reconhecer vou testar.

fredericotrin

Ola pessoal.
Eu não consegui resolver o problema do meu arduino e ainda por cima cometi um erro sem querer. Deletei do Gerenciador de Dispositivos o drive do meu arduino. Como faço agora. Ele fica com o LED ligado direto e o meu pc não reconhece ele para instalar um novo drive.

barroso26jonathan

Estou exatamente o mesmo problema do fredericotrin, alguém encontrou uma solução? Já estou achando que a placa está com defeito. =(

jarmando

Olha o que esses caras fizeram ai : http://forum.arduino.cc/index.php?topic=150690.0


Eu tb nao conseguia acessar o bicho. Set a com em ferramentas/porta . E tambem mude para ferramentas/Programador : arduino as isp.

ilzo

Perfeita a solução de regravar um outro programa durante o intervalo que a placa se conecta.
O programa anterior por algum motivo acabou gerando problemas.

Go Up