Go Down

Topic: Unable to mount network drive to Yun2 (Read 604 times) previous topic - next topic

kharjacobs

I've been trying  unsuccessfully to use samba to mount a shared drive on a window machine, and need some suggestions.  Here's a bit of what I've tried:

root@ArduinoYun:~# mount //<IP address>/j /mnt/J
mount: mounting //<IP address>/j on /mnt/J failed: No such device


root@ArduinoYun:~# smbclient //<IP address>/j -U <user name>
Enter <user name> password:
protocol negotiation failed: NT code 0xc000020d


and finally

root@ArduinoYun:~# smbclient -L //<IP address>/ -U <user name>
Enter <user name> password:
protocol negotiation failed: NT code 0xc000020d


I can't seem to find anyone else who's gotten stuck with the error code "0xc000020d" which Windows says is "STATUS_CONNECTION_RESET"

I can access the network drive from other windows computers, just not the Yun.

Thanks for your help.

ottsm

#1
Jan 13, 2019, 05:53 am Last Edit: Jan 13, 2019, 05:55 am by ottsm
I have a Yun Rev 2 and was able to get it to work.  Not sure I did it the correct or easiest way but hope it helps you.
1. Type in your Yun IP address on a web browser and type password to log in.  Press the "configure" button.
2. Press the "advanced configuration panel (luci)".
3. Select "System" and then "software".
4. Press "Update Lists" (if first time after boot).  Wait of few seconds for it to update.
5. Select "Available packages"
6. In the filter area type "samba" and press "Find package".
7. I picked "samba36-server" good bad or indifferent.  Maybe it should have been client, luci-app-samba already appears to be loaded.
8. Install the package.
9. Can't remember if I did a reboot at this point but you should be able to go under "System" and then "Startup".
10. Make sure samba is in the list and is started.
11. Next select "System" and then "Mount Points".
12. Under Mount Points select "Add".
13. Now it gets a little tricky, you will need to do some custom settings.  When all is said in done and you get back to where the mount point is added your mount point should look like;
Enabled checked, device name of your SD card, Mount Point /mnt/sda1, Filesystem vfat, Options umask=000, Root no, Check no.
14. Next select "Services" and then "Network Shares".
15. Click the "add".  You should have the following in the row when done;
Name arduino, Path /mnt/sd/arduino, Allowed users blank, Read only not checked, Allow guest checked, rest is blank.

Don't remember if you have to reboot or not.

You should be able to get into Windows 10 and map it to a drive.  It will be something like //192.168.0.15/arduino

Hope this helps, this use to be the old way on my Dragino Yun boards, it worked on the Yun Rev2 but with some extra unknowns.  Maybe I didn't have to do any or some of the steps but it was just my routine to get things going with the older boards. 

Go Up