Go Down

Topic: HILFE !!!! Problem mit Arduino Nano und WS2182! weiss nicht weiter (Read 500 times) previous topic - next topic

misterak20

Hallo,

ich wollte meinem Sohn ein Laserschwert basteln. Es hapert jedoch am elektronik teil.
komme mit dem arduino nano (aitmel 328P) irgendwie nicht zurecht.

ich habe diese anleitung zugrunde gelegt und danach gehandelt:

https://www.hackster.io/Modustrial_Maker/neopixel-lightsabers-w-party-modes-arduino-controlled-3e5a0d

und diesen code verwendet:

https://github.com/modustrialmaker/Lightsaber_single_blade_neopixel/blob/master/Rei_lightsaber/Rei_lightsaber.ino

habe alles so gemacht. der schalter ist auch blau beleuchtet wenn ich ihn drücke. am arduino leuchtet die power led durchgehend wenn strom drauf ist.
nur die led schnur tut nichts!

sobald strom verbunden wird blinken sie für eine milisekunde kurz einmal auf. aber auch nicht alle. sonst tut sich nichts.
was mach ich falsch?? das ist doch eigentlich copy paste für doofe? oder nicht. wo liegt der fehler?
warum leutet die schnur nicht?  (WS2182B mit 144 leds)

weiss nicht mehr weiter.


HotSystems

#1
Feb 10, 2019, 10:59 pm Last Edit: Feb 10, 2019, 11:05 pm by HotSystems
Was soll dieser blöde Artikel Titel ?
Hast du keine besseren Ideen ?
Wie soll da jemand auf dein Problem aufmerksam werden ?.
Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

misterak20

warum denn blöder artikel. da ist das diagramm zu finden nach dem ich alles verbunden habe.
und der zweite link ist der code den ich benutzt habe

HotSystems

#3
Feb 10, 2019, 11:03 pm Last Edit: Feb 10, 2019, 11:08 pm by HotSystems
Ok.....mein Fehler.

Ich meinte natürlich blöder Titel.

Edit:

Ok, das liest sich besser.

Du solltest aber deinen verwendeten Sketch hier posten.
1. Evtl. hast du ja einen Copy & paste Fehler drin.
2. Dann muss nicht jeder den Sketch umständlich runtergeladen.
Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)


HotSystems

Ja, gesehen und auch was angemerkt.

Was für eine Spannungsversorgung hast du dran ?
144 Leds brauchen schon mal ca. 8A wenns hoch kommt.
Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

misterak20

Benutze einen 3,7v lio ionen akku mit 3000mah mit step up auf 4,95 v gebracht

uwefed

Benutze einen 3,7v lio ionen akku mit 3000mah mit step up auf 4,95 v gebracht
Ok und wieviel Strom kann der StepUp liefern?
Grüße Uwe

wapjoe

Ich weiß nicht ob es einen Unterschied macht, aber du benutzt:
Quote
WS2182B mit 144 leds
und im Sketch steht in Zeile 11:
Quote
#define LED_TYPE WS2812
Vielleicht musst du deinen Sketch doch noch anpassen, aber ich kenne beide Typen nicht.
Das Problem an Zitaten aus dem Internet ist, du weißt nicht ob die wahr sind!

- Zitat Leonardo da Vinci -

misterak20

AZDelivery MT3608 DC-DC Netzteil Adapter Step up Power Supply Modul
Die geben 7% Verlust an aber einen maximalen ausgangsstrom von 2A

uwefed

Die WS2812 und WS2812B sind fast gleich. Der WS2812 hat 2 Anschlüsse mehr wobei nur einer angeschlossen ist und eine Versorgungsspannung für die internen LEDs ist (getrennt von der Versorgungsspannung für die steuerung).

Ein Streifen mit WS2812 und WS2812B sind in der Ansteuerung gleich.

Der Wandler kann 2A liefern. Das ist zuwenig für 144 LEDs.

Grüße Uwe

Helmuth

Quote
sobald strom verbunden wird blinken sie für eine milisekunde kurz einmal auf.
Beim Anschalten sind die erstmal in einem undefinierten Zustand - manche an, mache aus - auf jeden Fall ziehen sie einen Strom > 0.

Die Problembeschreibung klingt nach einem Spannungseinbruch.

Miss mal die Spannung an den Einspeisepunkten, NACHDEM die Leds kurz aufgeleuchtet haben.

Gruß, Helmut

HotSystems

AZDelivery MT3608 DC-DC Netzteil Adapter Step up Power Supply Modul
Die geben 7% Verlust an aber einen maximalen ausgangsstrom von 2A
Und genau das reicht nicht, wie ich dir schon in #5 geschrieben habe.
Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

Gucke Dir mal diesen Stepup Converter an (musst Du aber definitiv aktiv kühlen)...

SG

misterak20

habe den step up nur vor den arduino geschaltet, damit der knapp 5v bekommt. den akku habe ich direkt mit dem led string verbunden. aber tut sich nichts.

mal einfach gefragt.

was muss ich denn machen um diese kackteil zum laufen zu bringen?
mein problem ist das das innenteil des schwertes nur einen 24mm durchmesser hat. Länge ca. 14-16 cm

damit ich nicht immer das schwert öffnen muss habe ich an akkus gedacht.

ich benötige 2 neopixel schnüre mit jeweils ca. 100-144 leds
einen arduino nano, einen step-up / step down für die stromzufuhr des arduino,
ein lademodul für die/den akkus, dazu li ion akku/akkus (aber welche und wieviele)
dazu wiederstände und resistor? und halt einen schalter zwecks anmachen, ausmachen.

bin langsam am verzweifeln.

Go Up