Go Down

Topic: NTC Abweichung vom Datenblatt (Read 378 times) previous topic - next topic

gsezz

Feb 11, 2019, 10:36 pm Last Edit: Feb 11, 2019, 10:37 pm by gsezz
Hallo,
Ich wollte gerade eine kleine Temperatursteuerung für eine Heizmatte basteln, messe aber zu hohe Werte.

Verwendet habe ich diesen NTC.
Datenblatt
Widerstandstabelle

Um auszuschließen dass das Problem in Code oder Schaltung liegt habe ich den NTC wieder ausgelötet und nun vor mir auf einer Silikonmatte liegen. Ich messe 9.0kohm, was laut Tabelle ca 27-28°C entsprechen soll. (Ich habe einige Minuten gewartet bis sich der Wert stabilisiert hat).
Mein Raumthermometer sagt 22°C. Ich weiß nicht wie genau das ist, aber dass die Raumtemperatur weit von 28°C entfernt ist kann ich auch ohne Thermometer mit Gewissheit sagen.

Jetzt ist meine Frage, liegt der NTC so weit daneben? Laut Datenblatt soll er doch eine Tolleranz von 0.5% haben. Oder beachte ich etwas nicht?


gregorss

#1
Feb 11, 2019, 11:03 pm Last Edit: Feb 11, 2019, 11:08 pm by gregorss
Jetzt ist meine Frage, liegt der NTC so weit daneben? Laut Datenblatt soll er doch eine Tolleranz von 0.5% haben. Oder beachte ich etwas nicht?
Dass der NTC so weit daneben liegt, scheint mir sehr unwahrscheinlich.

Bist Du sicher, dass das die richtige Widerstandstabelle für Deinen NTC ist?

Gruß

Gregor
Bei Vollmond ist Neuerde.

uwefed

Ich weiß auch nicht.
Du müßtest bei 22°C ca 11,2kOhm haben.
Ich glaube auch Du kannst Schon 22 von 28 °C unterscheiden.
Bei einer Messung mit einem digitalen Multimeter kann eine Eigenerwärmung des NTC durch den Meßstrom ausgeschlossen werden.
Grüße Uwe

SpaghettiCode

#3
Feb 12, 2019, 07:37 am Last Edit: Feb 12, 2019, 07:45 am by SpaghettiCode
Hi,

ich habe auch schon mit diesem NTC gearbeitet, mit einem NTC TS-NTC-103A, und habe sehr genaue Ergebnisse erhalten!
Im vergleich zu anderen Sensoren und Thermometern (5 Stück auf dem Tisch versammelt) lag er immer im Bereich der Anderen (< 1 Grad Abweichung untereinander). Das Einzige was er nicht mag ist absolut stehende Luft, dann zeigt er schon mal 1 Grad mehr an, aber mehr auch nicht.
Ein paar Fragen:
Benutzt Du einen genauen Widerstand im Spannungsteiler (0,1%)?
Benutzt Du zum errechnen die Steinhart-Hart Koeffizienten, und die entsprechende Formel dazu?
Ist der Sensor (Spannungsteiler) immer eingeschalten, oder nur zur Messung selbst?
Das richtige Datenblatt verwendet, es gibt den NTC TS-NTC-103, und den mit "A"?

Gruß André

Katsumi_S

Eventuell ist auch der Sensor defekt. Bei unseren NTC und PTC die wir in unseren Motoren verbauen, sind auch immer wieder einzelne defekt und weichen z.B. von den 32,7kOhm auf 68kOhm ab! Auf Nachfrage bei unserem Lieferanten, warum da defekte Sensoren dabei sind, wurde uns mitgeteilt das 10% der Sensoren geprüft werden! Alles andere wäre zu teuer. Stückprüfung würde den Preis ziemlich in die Höhe treiben.

Vermutlich macht es B+B auch nicht anders. Du kannst ja mal bei Conrad oder B+B nachfragen was Du mit dem Teil machen sollst wenn er so weit abweicht.

Gruß, Jürgen


gsezz

Ich benutze keinen 0.1% Widerstand, sondern einen 5% dessen genauen Wert ich in die Formel eingetragen habe.
Ja, ich errechne die Temperatur nach den Steinhart-Hart Koeffizienten, und erhielt vom Arduino auch sehr genau den Wert zu dem mich die Messung mit dem Multimeter und das Nachschlagen in der Tabelle bringt. Also in Sachen Software und Schaltung habe ich eigentlich keine Probleme. Nur passt der Widerstand des NTCS irgendwie nicht zu dem was er laut Tabelle haben sollte.

Ich muss zugeben dass ich mir gerade nicht sicher bin ob ich den 103 oder 103A habe. Bin auch gerade auf der Arbeit und kann nicht nachschauen. Aber bei 9kohm unterscheiden sich deren Tabellen kaum, das liegt bei beiden NTCs zwischen 27-28°C, was definitiv weit mehr ist als die Raumtemperatur.


Mir ging es hier in erster Linie darum abzuklären dass ich nicht total auf dem Schlauch stehe, und falsch messe, oder so.
Also, wenn ich nur den Widerstand des NTC außerhalb der Schaltung messe, dann sollte der bei 22°C Raumtemperatur in etwa bei 11.2kohm liegen, und nicht bei 9.0kohm.
Ich werde mal ausprobieren ob die Abweichung wenigstens linear ist, dann kann ich vielleicht einfach einen Korrekturfaktor einsetzen. Ich will damit nur eine Lipo-Heizung steuern. Ob die Akkus nachher 3°C wärmer oder Kälter sind spielt eigentlich keine Rolle. Es wurmt mich nur schon mit einem falschen Messwert an die Sache ran zu gehen. ;)

chefin

Ich würde mal Eigenerwärmung durch Messtrom nicht ganz zu den Akten legen. Versuch mal, das ganze so gut es geht mit Aluminium zu kühlen. Alu leitet Wärme schnell ab, sollte also beim messen den Wert senken gegenüber dem messen ohne diese Kühlung.

Wenn du das feststellst, hast du Eigenerwärmung durch Messstrom. Wenn nicht, dann kannst du es zumindest definitiv ausschliessen. Dann bleiben nicht mehr all zu viele Möglichkeiten über.

gsezz

Ok, danke euch.
Ein Kühlkörper am NTC hat nichts geändert. Ich habe überlegt ihn einfach in der Software zu kalibrieren. Aber ich werde wohl einfach einen anderen besorgen.

uwefed

Ich würde mal Eigenerwärmung durch Messtrom nicht ganz zu den Akten legen.
Bei einem Spannungsteiler und einem niederohmigen NTC kann ich mir das vorstellen.

Bei einem ca 10kOhm Widerstand und einem Digitalmultimeter kann ich mir das nicht vorstellen.

Grüße Uwe

Go Up