Go Down

Topic: avrdude: stk500_recv(): programmer is not responding (Read 556 times) previous topic - next topic

karramarro

Hi,
I just started with the Arduino Starter Kit.
I am uploading the Blink program but it is giving some problems I cannot fix.
I have checked lots of online answers in forums but it seems that nothing helps me.

The ON green light is on. And the L light is blinking with an specific pattern (3 fast blinks and same time off). I tried connecting a LED light to check the bootloader and apparently it is OK, it blinks.

I have this message:

Sketch uses 930 bytes (2%) of program storage space. Maximum is 32256 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00
Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.


I have tried with different Boards, different Ports and different programmers, but I cannot get the right one.

I have the ATMEGA328P-PU processor and I am using a macbook Mojave 10.14.3. And I as this computer has no usb plug, I am using an adaptor with different types of plugs.

Please, help me!!

Thanks

pert

Please do this:
  • File > Preferences > Show verbose output during: > compilation (uncheck) > upload (check) > OK
  • Sketch > Upload
  • After the upload fails you'll see a button on the right side of the orange bar "Copy error messages". Click that button.
  • Paste the error messages in a reply here USING CODE TAGS (</> button on the forum toolbar).


Please post a link to where you bought the Arduino Starter Kit from. There are several products being sold under this name and we need to know which board you're using.

Go Up