Go Down

Topic: Ayuda con arduino uno (Read 248 times) previous topic - next topic

juan5826

Mar 04, 2019, 07:42 pm Last Edit: Mar 13, 2019, 04:08 am by surbyte Reason: Errores y códigos deben ir con etiquetas
Hola gente, soy nuevo en esto y estoy teniendo un problema que paso a comunicarles a ver si alguien tiene respuesta.

Tengo un arduino uno, por lo que he podido ver es un clon, el problema que tengo es que he tratado de controlar un PT2322,  escribí el sketch y funciono modifique parámetros etc, luego de haber desconectado el arduino del pc al volver a conectarlo ya no funciona ni siquiera aun volviendo a cargar el sketch, pensando en mi posible error de novato en el sketch, decidí hacer uno nuevo y ahí nuevamente funciono... hasta que desconecte el arduino, al conectarlo nuevamente ya no funciona, cargo los sketch y nada...
Si cargo por ejemplo el sketch de "dirección" funciona, pero los que realice para controlar el pt2322 no funcionan mas. Les dejo mi codigo (muy simple), igual no creo que sea un tema de codigo, me parece que hay algo en hardware que no me doy cuenta o quizás problemas en el arduino?
El circuito que hice para el PT2322 es el de aplicación de su hoja de datos.

Code: [Select]
#include <Wire.h>
 

void setup() {
  delay(300);
  Wire.begin();
  Wire.beginTransmission(0x44);
 
  Wire.write (0xff); // Borro registros
  Wire.write (0xc7);  //Habilito las entradas
  Wire.write (B11100100); (B11010010);  // seteo volumen -42db
  Wire.write (B01110110); //quito mute, apago 3d, prendo control de tonos
  Wire.write (B11100000);   //le digo que no atenue la señal master volumen
 
  Wire.endTransmission(0x44);
  delay(300);
}

void loop() {
  // put your main code here, to run repeatedly:

}

Kike_GL

#1
Mar 04, 2019, 11:55 pm Last Edit: Mar 05, 2019, 01:14 am by surbyte
Lee las normas del foro. Debes poner tu código completo usando las etiquetas apropiadas.
Saludos, Kike_GL

juan5826

Gracias por responder, el codigo es completo, en cuanto a las etiquetas apropiadas no entiendo bien a que te refieres

Jorgeturi

#3
Mar 05, 2019, 02:12 am Last Edit: Mar 05, 2019, 02:24 am by Jorgeturi
Hay un botoncito con la forma de  <> o similar, si te acercas dice "code". Debes clickear ahí para luego pegar el código dentro, así estará bien puesto, agradable a la vista y ordenado
Saludos!

Editado** Te recomiendo editar todo y agregar, no agregar comentarios innecesariamente, podes en el post principal o el primer comentario
Saludos nuevamente! xD

juan5826

Gracias por tu ayuda, ya lo voy a colocar en la forma correcta

surbyte

Parece mentira. SI no interviene el administrador del foro, no hay forma que se le haga caso al pedido de un forero experimentado como Kike_GL.

Lee las normas del foro para que entiendas porque te pido cada una de las siguientes cosas:

1. Edita el título. Coloca un título acorde con tu problema. Ayuda con Arduino UNO es como poner Me llamo Pedro
2. Los códigos van con etiquetas de código, al igual que enlaces e imágenes.
No lo olvides.
Si no lo haces, siempre alguien o un moderador te llamará la atención.

En el primer hilo de esta sección estan las normas.


Kike_GL

setup() se ejecuta una sola vez al arrancar el Arduino.

Si quieres hacer algo "por mas tiempo" ponlo en loop()
Saludos, Kike_GL

Go Up