Go Down

Topic: Sketch upload problems with Arduino Pro Mini  (Read 445 times) previous topic - next topic

flagtrax

I don't have a "official" pro-mini as I said, but I have a pinout drawing, and yours is different. In addition to that , your FTDI connections (as I see it in the photo) don't seem to be as they should be.


                                         FTDI       PRO-MINI
                                         
It looks to me like you have DTR TO   TX0         DTR should go to DTR
                                         RXI         RXI         RXI should go to TX0
                                         TX0         VCC       Here you're putting Vcc on the transmit lead
                                     Vcc(3.3v)     GRD       This would be a short
                                          CTS        GRD

I May be mistaken by the angle of your photo, but that's what it looks like. if it is angle view I'd look at those connections carefully. If you look at the photo I attached, you should see:

                                       FTDI             PRO-MINI

                                       DTR              DTR
                                       RX                TX0
                                       TX0               RX
                                       VCC               VCC
                                       CTS                GRD
                                       GRD               GRD

I'll attach a photo of the Official Pro mini pinout.

BJHenry

That pin alignment looks fine. Given the symptoms you've described I think your board is cactus- the simple fact of the matter is that with nothing else plugged in the microcontroller itself shouldn't get hot.

Parvizal

Okay, that's a shame I was hoping that I could get it back. Thanks for everyone's help though!

BJHenry

You're welcome. At least they're not too expensive!

Go Up