Go Down

Topic: MKR Zero seems to block reset of DS3231 module (Read 309 times) previous topic - next topic

Bushedo

Can anyone tell me why the RTClib functions that reset the time on the DS3231 module don't seem to function with the MKR Zero?  I can reset the module's time using the example code and an Uno.  But, when I connect the module to the MKR Zero, the time always resets to the same time from several months ago  even though I do the same system time call: (  rtc.adjust(DateTime(F(__DATE__), F(__TIME__))); ).  It appears that the MKR Zero is retaining this date-time from previous experiments using the internal RTC functions.  Can't find the instructions for posting my code, but doubt it is a code issue.

Bushedo

Actually,

I think the RTClib is not actually working the DS3231.  Has anyone had success using RTClib with a DS3231 and a MKR Zero?

Bushedo

I'm making one more try at this.  My problem is that the MKR Zero doesn't seem to work with the DS3231 real time clock module using any of the libraries I have tried including RTClib.  The module works with an UNO fine.  The MKR can run other I2C devices and when I run I2C Scan, the address for the module shows up along with the address for the non-volatile memory chip on the module.  It also shows the address for the BME280 that is also hung on the I2C bus as part of the project I'm trying to finish.  The BME works great on the MKR.  When I try any of the example programs for the DS3231 on the MKR, it always reports the same date Feb 2, 2019 (Groundhog Day in the USA!).  Even when code should have reset the clock to the compile time of the code.  Beginning to feel like Bill Murray here.  Hope someone more experienced with the MKR Zero can offer some ideas what I can try to make this work.  Did find the instructions for posting code, but see no reason to do so since the issue is found on any number of example sketches. 

Would appreciate even educated guesses at this point.  Thanks for your consideration.

Go Up