Go Down

Topic: FireBeetle ESP 32 C++config.h issue (Read 266 times) previous topic - next topic


Hello all
I am new to using esp devices.  When ever I try to upload the most basic or complicated code to my FireBeetle ESP 32, it gives me this error in the bottom.  I have downloaded the correct board library and followed all the instructions on how to set up the device.  Thanks in advance. 

In file included from f:\games and tech stuff\arduino\arduino-1.8.8-windows\arduino-1.8.8\portable\packages\esp32\tools\xtensa-esp32-elf-gcc\1.22.0-61-gab8375a-5.2.0\xtensa-esp32-elf\include\c++\5.2.0\memory:62:0,

                 from F:\Games and Tech Stuff\Arduino\arduino-1.8.8-windows\arduino-1.8.8\portable\packages\esp32\hardware\DFRobot_FireBeetle-ESP32\0.0.9\cores\esp32\Esp.cpp:25:

f:\games and tech stuff\arduino\arduino-1.8.8-windows\arduino-1.8.8\portable\packages\esp32\tools\xtensa-esp32-elf-gcc\1.22.0-61-gab8375a-5.2.0\xtensa-esp32-elf\include\c++\5.2.0\bits\stl_algobase.h:59:28: fatal error: bits/c++config.h: No such file or directory

compilation terminated.

exit status 1
Error compiling for board FireBeetle-ESP32.


Try this:
  • Delete f:\games and tech stuff\arduino\arduino-1.8.8-windows\arduino-1.8.8\portable\packages. Please be very careful when deleting anything from your computer. When in doubt, back up!. This will remove all the boards you have installed via Boards Manager.
  • (In the Arduino IDE) File > Preferences
  • In the "Additional Boards Manager URLs" field, delete the URL you used to install this "DFRobot_FireBeetle-ESP32" thing.
  • In the "Additional Boards Manager URLs" field, enter the URL: https://dl.espressif.com/dl/package_esp32_index.json
  • Click "OK"
  • Tools > Board > Boards Manager
  • Wait for the downloads to finish.
  • Scroll down until you see "esp32 by Espressif Systems". Click on it.
  • Click "Install".
  • Wait for installation to finish.
  • Click "Close".
  • Tools > Board > FireBeetle-ESP32

Now try compiling again.

The above instructions will remove DFRobot's attempt at providing their own hardware package for ESP32 and install the official ESP32 hardware package, which is much more actively maintained. Since the officail ESP32 hardware package also supports the FireBeetle-ESP32, I can't think of any reason to use some outdated, possibly broken thing from DFRobot instead.


Thanks for the response. 
Everything you suggested worked until I tried to download the board.  This is the error I got.

Error downloading https://dl.espressif.com/dl/package_esp32_index.json



  • After you get that error, click the "Close" button.
  • Click on the black console window at the bottom of the Arduino IDE window.
  • Press "Ctrl + A". This will select all the text in the console window.
  • Press "Ctrl + C". This will copy the selected text to the clipboard.
  • In a reply here, click the </> button on the forum toolbar. This will insert code tags into the reply field.
  • Press "Ctrl + V". This will paste the copied text from the clipboard between the code tags.
  • Click "Post".

Go Up