Go Down

Topic: Newbie Help...No such file or directory. Compilation terminated. (Read 433 times) previous topic - next topic

Transam98

ok im a newbie here :) I keep getting a error... (when sending a file into the mega2560....Cant figure what im doing wrong ;( I think I have everything correct... it may be a directory problem...

If anyone can help Id REALLY appreciate it...

Im getting a error on a file (see title or pic below.)

I CAN see the FILE in a folder that is one LEVEL up...


the file/error: Adafruit_NeoPixel.h: No such file or directory

I can see it in the FOLDER one level up in C:\Users\Administrator\Documents\Arduino\libraries\NeoPixel

Im sure it may be or is a directory tree (folder location problem) but im not sure ;(

Thanks in advance

pert

What is your sketchbook folder set to in File > Preferences > Sketchbook location?

Transam98

@pert , thanks on the reply :)... just now saw it....
the location is:C:\Users\Administrator\Documents\Arduino

here is all the Folders etc....

C:\Users\Administrator\Documents\Arduino\pushbuttonlinein\Libraries\NeoPixel
C:\Users\Administrator\Documents\Arduino\pushbuttonlinein\Libraries\FastLED
C:\Users\Administrator\Documents\Arduino\pushbuttonlinein\Libraries
C:\Users\Administrator\Documents\Arduino\pushbuttonlinein (this folder has all of the INO Files for the project)

pert

Libraries must be installed to the libraries subfolder of your sketchbook folder. In your case, that is C:\Users\Administrator\Documents\Arduino\libraries.

You need to copy C:\Users\Administrator\Documents\Arduino\pushbuttonlinein\Libraries\NeoPixel to C:\Users\Administrator\Documents\Arduino\libraries.


Transam98

Ive looked at the link and dont see anything new....

The place I got the files from already had the library files... and I put there where the author said to...

so I still dont understand whats wrong ;( which sucks as ive spent a bit of $$ on this project hardware and all and have a paperweight ;(

This is where the project is from and it has the link to all the files in the description...


https://www.youtube.com/watch?v=Ct2aSvVlego
& the files are under MORE INFO

UKHeliBob

Please can you post the code that you are trying to compile and the full error messages that you get

Please read this before posting a programming question
Please do not send me PMs asking for help.  Post in the forum then everyone will benefit from seeing the questions and answers.

Transam98

ok here goes let me know if im missing something :)
I RT click the file named: pushbuttonlinein.ino
and it OPENS arduino with the CODE below in TAB # 1.... and about 7+ more tabs open beside it (code for the additional options for this project)


it wont let me post the code here... over 9000 characters... it wont let me attach the RAR file.... 9 MB

this is the link to the RAR
https://www.youtube.com/redirect?q=https%3A%2F%2Fdrive.google.com%2Fopen%3Fid%3D1mHazgA3IgxVpmz_T7RL1ijHrEege9Vjk&event=video_description&redir_token=k5FHEbtpj8Kxe-uSQAIxGHl2asF8MTU1MzQ0NzU5MEAxNTUzMzYxMTkw&v=Ct2aSvVlego

Its the one that says: (in the folder)... push_button_line_in

And it has the libraries included...

/////////////ERROR INFO///////////
Arduino: 1.6.5 (Windows 8.1), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

pushbuttonlinein.ino:2:35: fatal error: Adafruit_NeoPixel.h: No such file or directory
compilation terminated.
Error compiling.

 This report would have more information with
 "Show verbose output during compilation"
 enabled in File > Preferences.

** My directory TREE is above in a previous mssg in this thread...... only 4 or 5 mssgs above...

thanks !


cattledog

Quote
The place I got the files from already had the library files... and I put there where the author said to...
Did you put the library files where @pert told you to put them?

Quote
Libraries must be installed to the libraries subfolder of your sketchbook folder. In your case, that is C:\Users\Administrator\Documents\Arduino\libraries.

Transam98

yep, I believe Ive done all correctly :) here is a screen shot showing directory layout and error etc :)

Am I missing anything or anything else I need to check ?

as from the screenshot... it says this is missing: Adafruit_NeoPixel.h

im not sure where that is supposed to come from (a library maybe ?) as it isnt in his libraries he included with the project :)

cattledog

Quote
here is a screen shot showing directory layout


Your file layout does not look correct.

At the level of Documents>Arduino there should be sketches in folders and a folder called libraries.

In that library folder there should be Adafruit NeoPixel and FastLed. You can install them through the library manager of the ide.


Transam98

thanks on the reply !
ughhhh how annoying....

So I went to sketch->include library->manage
and typed in the search bar... FAST LED and NEOPIXEL,,,,,

Added/installed both :)
restarted arduino software...
loaded file (rt click edit arduino (main file called pushbuttonlinein.ino)
it opens, pressed right arrow... got this error...


Arduino: 1.6.5 (Windows 8.1), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

In file included from pushbuttonlinein.ino:3:0:
C:\Users\Administrator\Documents\Arduino\libraries\FastLED/FastLED.h:14:21: note: #pragma message: FastLED version 3.002.006
 #    pragma message "FastLED version 3.002.006"
                     ^
pushbuttonlinein:1748: error: invalid conversion from 'void (*)(boolean) {aka void (*)(bool)}' to 'void (*)()' [-fpermissive]
pushbuttonlinein:1748: error: invalid conversion from 'void (*)(uint8_t) {aka void (*)(unsigned char)}' to 'void (*)()' [-fpermissive]
invalid conversion from 'void (*)(boolean) {aka void (*)(bool)}' to 'void (*)()' [-fpermissive]

  This report would have more information with
  "Show verbose output during compilation"
  enabled in File > Preferences.


cattledog

Quote
In file included from pushbuttonlinein.ino:3:0:
C:\Users\Administrator\Documents\Arduino\libraries\FastLED/FastLED.h:14:21: note: #pragma message: FastLED version 3.002.006
 #    pragma message "FastLED version 3.002.006"
                     ^
I do not think this is a problem as I see this in the library
Code: [Select]
#if (__GNUC__ > 4) || (__GNUC__ == 4 && __GNUC_MINOR__ >= 4)
#define FASTLED_HAS_PRAGMA_MESSAGE
#endif

#define FASTLED_VERSION 3002006
#ifndef FASTLED_INTERNAL
#  ifdef FASTLED_HAS_PRAGMA_MESSAGE
#    pragma message "FastLED version 3.002.006"
#  else
#    warning FastLED version 3.002.006  (Not really a warning, just telling you here.)
#  endif
#endif


You can certainly try to run some of the Fast Led library examples to verify that all is OK.

Quote
pushbuttonlinein:1748: error: invalid conversion from 'void (*)(boolean) {aka void (*)(bool)}' to 'void (*)()' [-fpermissive]
pushbuttonlinein:1748: error: invalid conversion from 'void (*)(uint8_t) {aka void (*)(unsigned char)}' to 'void (*)()' [-fpermissive]
invalid conversion from 'void (*)(boolean) {aka void (*)(bool)}' to 'void (*)()' [-fpermissive]
You will have to post the code at line 1748.


Transam98

unfortunately im a newbie and have no clue ;( 1st time ive ever owned a arduino ;(

I figured it would be straightforward install arduino s/w
load code program arduino and bootup and wire up hardware :) (lol)

Ive flashed stuff before, programmed microcontrollers/eproms etc
but have no idea why this isnt more straightforward ;(

Watched the youtube video of this project, got the code did the wiring of the circuit etc... but have failed on getting code into arduino ;(

pert

You are using a very old version of the Arduino IDE. Since the Arduino AVR Boards hardware package used by the Arduino Mega is bundled with the Arduino IDE, you are also using a very outdated version of Arduino AVR Boards. In more recent versions of Arduino AVR Boards, Arduino updated to a new compiler version. That compiler update caused some bad code that compiled with the old compiler to no longer compile. In order to provide backwards compatibility, Arduino added the -fpermissive compiler flag, which caused the old bad code to continue to compile. As a side effect of -fpermissive, it allowed even more bad code to compile than ever before. The pushbuttonlinein sketch you found contains some of this bad code, and thus will only compile if you are using a modern version of Arduino AVR Boards. Although it is probably possible for you to just update Arduino AVR Boards via Boards Manager, I would recommend that you go ahead and update your Arduino IDE instead, unless you actually have a good reason for sticking with Arduino IDE 1.6.5.

You can download the Arduino IDE here:
http://www.arduino.cc/en/Main/Software

Go Up