Go Down

Topic: batman-adv on arduino-yun (Read 331 times) previous topic - next topic

bijay_karki

hello i am trying to use batman adv on two arduino yun V2 devices where i did everything as said in:

https://openwrt.org/docs/guide-user/network/wifi/mesh/batman
http://www.radiusdesk.com/old_wiki/technical_discussions/batman_basic

after i configure all these on both of them i connect ethernet cable to node1 and create bridge LAN with WAN to get internet from cable(WAN). also i disabled dhcp server of LAN so that i get ip address from ethernet(wan:router is present on other side) which node 1 gets. but node 2 which i can ping using batctl ping but can't get ip from router through node1.  what might be the problem?

can anyone please help?

config files of node1 and node2
 
node 1
/etc/config/wireless
config wifi-device 'radio0'
   option type 'mac80211'
   option channel '11'
   option hwmode '11g'
   option path 'platform/ar933x_wmac'
   option htmode 'HT40'
   option txpower '18'

config wifi-iface
   option device 'radio0'
   option mode 'ap'
   option encryption 'none'
   option ssid 'arduino1'
   option network 'lan wan'

config wifi-iface 'wmesh'
   option device 'radio0'
   option ifname 'adhoc0'
   option network 'mesh'
   option mode 'adhoc'
   option ssid 'mesh'
   option bssid '02:CA:FE:CA:CA:40'

/etc/config/network

config interface 'loopback'
   option ifname 'lo'
   option proto 'static'
   option ipaddr '127.0.0.1'
   option netmask '255.0.0.0'

config globals 'globals'
   option ula_prefix 'fd3c:e0d9:3614::/48'

config interface 'lan'
   option type 'bridge'
   option force_link '1'
   option proto 'static'
   option netmask '255.255.255.0'
   option ip6assign '60'
   option _orig_ifname 'wlan0 bat0'
   option ipaddr '192.168.100.25'

config interface 'mesh'
   option ifname 'adhoc0'
   option mtu '1532'
   option proto 'batadv'
   option mesh 'bat0'
   
config interface 'wan'
   option proto 'dhcp'
   option _orig_ifname 'eth1'
   option _orig_bridge 'false'
   option macaddr 'A8:40:41:11:EB:AC'
   option ifname 'eth1'

node2
/etc/config/wireless

config wifi-device 'radio0'
   option type 'mac80211'
   option channel '11'
   option hwmode '11g'
   option path 'platform/ar933x_wmac'
   option htmode 'HT40'
   option txpower '18'

config wifi-iface
   option device 'radio0'
   option mode 'ap'
   option encryption 'none'
   option ssid 'Arduino2'
   option network 'mb'

config wifi-iface 'wmesh'
   option device 'radio0'
   option ifname 'adhoc0'
   option network 'mesh'
   option mode 'adhoc'
   option ssid 'mesh'
   option bssid '02:CA:FE:CA:CA:40'


/etc/config/network

config interface 'loopback'
   option ifname 'lo'
   option proto 'static'
   option ipaddr '127.0.0.1'
   option netmask '255.0.0.0'

config globals 'globals'
   option ula_prefix 'fd3c:e0d9:3614::/48'

config interface 'lan'
   option type 'bridge'
   option force_link '1'
   option proto 'static'
   option netmask '255.255.255.0'
   option ip6assign '60'
   option _orig_ifname 'wlan0'
   option ipaddr '192.168.100.6'

config interface 'mesh'
   option ifname 'adhoc0'
   option mtu '1532'
   option proto 'batadv'
   option mesh 'bat0'
   
config interface 'mb'
        option ifname 'bat0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.100.26'
        option netmask '255.255.255.0'

config interface 'wan'
   option proto 'dhcp'
   option _orig_ifname 'eth1'
   option _orig_bridge 'false'
   option macaddr 'A8:40:41:12:27:88'
   option ifname 'eth1'

bijay_karki

in /etc/config/wireless

remove

    option _orig_ifname 'wlan0 bat0'

type

    option ifname 'eth0 bat0' (for node 1. Remember bat0 only for node 1)

    option ifname 'eth0' (for node 2)

in /etc/config/network

make ipaddr of interface 'lan' and 'mb' in different subnet for node 2 (since ipaddr of node1 is 192.168.100.25 so ip addr of interface mb in node will be in same subnet 192.168.100.X whereas ipaddr of interface lan should be in different subnet 192.168.A(any except 100).B then follow same process for other nodes.

ShapeShifter

Thanks for following up and posting the solution you had found. I'm sorry nobody replied to your first request, but I guess nobody has run into your problem and had any help to offer.

But now that you've posted your solution, maybe it will help the next person who has this difficulty.

Go Up