Go Down

Topic: ESP8266-01 will not run as access point (Read 645 times) previous topic - next topic


I cannot get my ESP8266-01 standalone board to work as a WiFi unit. I've tried running programs that configure the unit in Access Point mode and in Station mode, but neither work. I've tried the suggestions of many resources on the Web, but this is the one I've spent most time with:


Using the wiring diagram shown on page 6 (apart from the connection to GPIO15, which I don't have access to):

I can successfully flash a program to the board using an Arduino Uno as a flash programmer. So far, so good. However, post-upload when I run the board 'operationally', the board doesn't work.

For simplicity, I'll focus only on my attempts to configure the unit in 'Access Point' mode. I uploaded the program on page 22 (GPIO0 low)

Code: [Select]

#include <ESP8266WiFi.h>

const char *ssid = "ESP8266 Access Point";
const char *password = "thereisnospoon";

void setup() {
  WiFi.softAP(ssid, password);
  Serial.print("Access Point \"");
  Serial.println("\" started");
  Serial.print("IP address:\t");

void loop() { }

and then re-powering the board with GPIO0 high, the WiFi network is not visible. I've ensured that all connections are good, I've used an external power supply capable of supplying 0.5 A, I've tried alternative programs/sketches (e.g. the Arduino example 'WiFiAccessPoint') but still the WiFi network does not become visible. I've run out of ideas. Can anyone please suggest what the problem might be?



try esp8266 arduino core version 2.4.2


try blink LED sketch just to make sure your ESP doesn't go into 'flash mode' when booting
Electrical Engineer

Go Up