Go Down

Topic: Virtual Wire Library Transmission (Read 130 times) previous topic - next topic

Julius217

I am currently working on an rc using two Arduino Uno's and a 433 MHz Transmitter and Reciever 433 MHz Transitter and Reciever from oddwires.com
I got all the code working except for the transmitting side. I used the serial monitor to figure out exactly what was being sent, and all it is sending is a 1. I need to be able to send an 8-bit signal with all the data from the controller readings. And then on the receiver side it would use bit() to extract each of the readings into what each should do.
I'm only posting the part of the code that needs to be fixed
Code: [Select]
void transmit()
{
  Serial.println ("Controller value transmitted is");
  Serial.println (vw_send((uint8_t *)controller, strlen(controller)));
  vw_send((uint8_t *)controller, strlen(controller));
  vw_wait_tx(); // Wait until the whole message is gone
}

jremington

#1
Mar 25, 2019, 04:28 pm Last Edit: Mar 25, 2019, 04:30 pm by jremington
Quote
I'm only posting the part of the code that needs to be fixed
The following prints the return value of the function vw_send().
Code: [Select]
  Serial.println (vw_send((uint8_t *)controller, strlen(controller)));

Post ALL the code, if you want help with the other errors.

Julius217

And it returns a 1 regardless of the situation. Throughout the rest of the code the serial monitor displays exactly what it should be. And this is the only place that I suspect there to be an error.


Go Up