Go Down

Topic: Facing problem while burning bootloader on ATmega328 (Read 102 times) previous topic - next topic

dev009

Mar 28, 2019, 02:47 pm Last Edit: Mar 28, 2019, 02:51 pm by dev009 Reason: added extra information.
Hi,
i am trying to flash boot-loader on ATmega328 using Arduino Nano.
I have done the connection as follows
Arduino Pin 13 -> chip pin 19.
Arduino Pin 12 -> chip pin 18.
Arduino Pin 11 -> chip pin 17.
Arduino Pin 10 -> chip pin 1 Reset

i m using 8MHz crystal and 22pf capacitor connected on pin 9 and 10.

Here part of boards.txt file i have added.
Code: [Select]

##############################################################
uno328.name=Arduino328
uno328.upload.protocol=arduino
uno328.upload.maximum_size=32256
uno328.upload.speed=57600
uno328.bootloader.low_fuses=0xff
uno328.bootloader.high_fuses=0xde
uno328.bootloader.extended_fuses=0x05
uno328.bootloader.path=optiboot
uno328.bootloader.file=ATmegaBOOT_168_atmega328_pro_8MHz.hex
uno328.bootloader.unlock_bits=0x3F
uno328.bootloader.lock_bits=0x0F
uno328.bootloader.tool=arduino:avrdude
uno328.build.mcu=atmega328
uno328.build.f_cpu=8000000L
uno328.build.core=arduino
uno328.build.variant=standard
##############################################################
atmega328bb.name=ATmega328(8 MHz internal clock)

atmega328bb.upload.protocol=arduino
atmega328bb.upload.maximum_size=30720
atmega328bb.upload.speed=57600

atmega328bb.bootloader.low_fuses=0xE2
atmega328bb.bootloader.high_fuses=0xDA
atmega328bb.bootloader.extended_fuses=0x05

atmega328bb.bootloader.file=atmega/ATmegaBOOT_168_atmega328_pro_8MHz.hex
atmega328bb.bootloader.unlock_bits=0x3F
atmega328bb.bootloader.lock_bits=0x0F

atmega328bb.build.mcu=atmega328p
atmega328bb.build.f_cpu=8000000L
atmega328bb.build.core=arduino:arduino
atmega328bb.build.variant=arduino:standard


atmega328bb.bootloader.tool=arduino:avrdude
atmega328bb.upload.tool=arduino:avrdude
##############################################################

Both configuration is not working.

I am getting following error after trying to flash bootloader.

Code: [Select]

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x15
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x15

avrdude: stk500_getparm(): (a) protocol error, expect=0x14, resp=0x14

avrdude: stk500_getparm(): (a) protocol error, expect=0x14, resp=0x01
avrdude: stk500_initialize(): (a) protocol error, expect=0x14, resp=0x10
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.

avrdude: stk500_disable(): unknown response=0x12
Error while burning bootloader.


Connected 10uf capacitor between VCC and GND also.
And my arduino ide version is 1.8.8.


Any help will be appreciated...

kprims

#1
Mar 28, 2019, 03:19 pm Last Edit: Mar 28, 2019, 03:28 pm by kprims Reason: Added MiniCore.
Quote
Connected 10uf capacitor between VCC and GND also
Connect 10uF capacitor between Reset and GND on the Nano after you load the "ArduinoasISP' sketch.

I recommend using Minicore. Works great and gives you many options.

https://github.com/MCUdude/MiniCore

Go Up