Go Down

Topic: problemi con stabilizatore (Read 183 times) previous topic - next topic

miky_police

Apr 08, 2019, 08:33 pm Last Edit: Apr 09, 2019, 01:17 am by UweFederer
Per rimanere in tema. io ho realizzato un circuito con un input non regolato 12v un 7805 tht per la 5v, un 78M06 per la 6v ed un LDO asm1117 3.3v, tutti e 3 con input sotto 12v (che poi ne erogava 11,5v). il 7805 non fa una piega (5,003v), idem il 7806 (6v spaccati), ma l l'LDO spara a 3,6v con tutti i problemi e rischi del caso. Qualcuno sa il perché? io una pseudo risposta me la sono data, la serie 78XX ha un input più "largo" (15v) come Vin max rispetto al LDO (12Vin max). Ma è davvero così?

EDIT: adesso ho visto meglio il tuo ultimo schematico. ottimo lavoro, ma mi sento di darti un consiglio. Se ti trovi una manciata di opto e spazio sulla board finale, rimpiazzerei i filtri rc dei pulsanti con 2 opto per l'appunto. Sono infallibili. Ormai non ne faccio più a meno. in china 100 opto con spedizione tracciabile stai sotto i 5 euro sicuro.
Il vero stupido è colui che fa e rifa la stessa cosa aspettandosi risultati diversi. A.E.

UweFederer

Ho separato il Tuo post dalla altra discussione.

Come hai montato / saldato il AMS1117?

Ciao Uwe


miky_police

#2
Apr 09, 2019, 10:59 am Last Edit: Apr 09, 2019, 11:03 am by miky_police
Un po di flussante a pennello sulle 4 piazzole, un'argentata con lo stagno su di queste, poggiato il componente in posizione e poi saldati uno ad uno i piedini.
Se la domanda era riferita alla tecnica hot air, no, non ho utilizzato quella tecnica, anche se ho la stazione saldante per farlo. L'hot air la uso con i componenti smd a 32 piedi come i formati tqfp, e non ho mai avuto problemi di sorta.
EDIT: l'LDO 3,3v deve alimentare solo un xbee.
Il vero stupido è colui che fa e rifa la stessa cosa aspettandosi risultati diversi. A.E.

uwefed

No, la domanda era che scheda hai usato; ha abbastanza rame da poter fungere da dissipatore.
A secondo del modello di Xbee consuma da 50mA (XBEE) fino a 340mA(XBee PRO versione USA)
Ciao Uwe

miky_police

la scheda è una semplice FR4 da 35um. Sinceramente non mi sono posto il problema di dissipazione dato il carico esiguo da sostenere. L'xbee è un S2 con antenna esterna saldata.
Da considerare che realizzai un altro pcb (diverso per funzioni, ma sul quale c'era sempre un xbee s2 oltre che l'atmega328p-au) alimentato a batteria 9v con 2 LDO serie AMS1117XX (5 e 3.3v) e non ho avuto problemi di sorta.
Il vero stupido è colui che fa e rifa la stessa cosa aspettandosi risultati diversi. A.E.

uwefed

XBee Serie 2 consumano fino a 40mA.
Se alimenti lo stabilizzatore 3,3V con 12V e con 40mA carico hai ca 350mW da dissipare.
Un AMS1117 senza superfice di rame adatta per dissipare tale potenza non funziona in modo affidabile.
Che con 9V funziona non fa testo visto che lo alimenti a 12V che sono alla fine ca 1/3 di potenza da dissipare in meno.
Ciao Uwe

miky_police

mmmh... in effetti a pagina 5 parla proprio del Pd e da indicazioni circa la superficie in rame da avere per garantire la dissipazione (anche se in linea di massima). questo implica che devo rifare il pcb, oppure interdire il Vin del regolatore e ponticellarlo sul Vou del 78M06 o meglio ancora sul 7805 (che sono entrambi muniti di dissipatore, ne avevo un po da parte di recupero ed ho pensato bene di installarli).
Il vero stupido è colui che fa e rifa la stessa cosa aspettandosi risultati diversi. A.E.

miky_police

A questo punto porgo un ultima domanda in merito al Pd. Se volessi realizzare un dissipatore passivo su pcb, dovrei realizzarlo sul piedino di Vout? GND? entrambi? ovvio è che nel caso di specie l'ams1117 offre il piedino del Vout come massima superficie di contatto disponibile.
Grazie per le dritte!
Il vero stupido è colui che fa e rifa la stessa cosa aspettandosi risultati diversi. A.E.

Go Up