Go Down

Topic: Issue with MKR WiFI 1010 Flashing Orange LED - Board not functioning (Read 174 times) previous topic - next topic

chriskane

Afternoon All,

I'm having some bother with my new Arduino MKR WiFi 1010 board. The problem I'm having is that occasionally (about 1 in every 5 attempts) when I try to upload a sketch, it seems to go into some sort of 'bootloader' mode. What I mean by this is that the BUILTIN Orange LED flashes by fading in and out (Not the CHRG LED). The computer can recognise the board as it makes the Windows device insertion tone when plugged in. When this happens to the board, it can not run any sketches and I cannot upload anything onto the board- rendering it useless. There is nothing attached to the Arduino, just the USB Cable.

Under normal operation, the board will connect to my computer under a low numbered port such as com4, and be fully working. However, when it is in this 'stuck flashing' mode, it will connect to the IDE under a high numbered port such as com21. Device Manager shows that it can detect the bootloader (see screenshot).

I have tried:

  • Removing the foam packaging from the bottom of the board
  • Pressing the reset button
  • Quickly double-tapping the reset button
  • Using a different USB Cable
  • Using a different USB protocol (2.0, 3.0)
  • Using a power only USB (no data connection)
  • Holding the reset button down when connecting to PC
  • Using a different computer
  • Using both the Web IDE and the Local one
  • Updating the firmware for the board once I have been able to get it out of this 'stuck flashing' mode previously.
  • Installing all the neccacary drivers and libraries to use this Arduino.
And all of that has made no difference. I can't for the life of me get this board working again, but I have been able to do it in the past by trying for hours- I'm not sure how I was able to fix it. As I mentioned above, this problem occurs when I click the sketch upload button in the Web or Local IDE. Thank you for your help in advance, this problem is driving me nuts!  :o


EDIT:

Just attempted the loop back test and I don't think it worked as the CHRG LED just kept flashing and there was no Windows device insertion tone.

Go Up