Go Down

Topic: Shield CNC V3 Arduino Uno (Read 123 times) previous topic - next topic

vanderer

Apr 16, 2019, 09:28 pm Last Edit: Apr 19, 2019, 12:03 am by surbyte Reason: Titulo editado, etiqueta para enlaces y visualización de imagenes.
Buenas a todos, tengo el siguiente problema, compre hace un tiempo una shield cnc v3.00 (http://www.robotlinking.com/), también cuento con arduino uno original, 4 driver Pololu A4988, motores nema 17 y fuente de 12 voltios de 20 amperios.
después de dar una larga lectura por todos los enlaces que encontré para hacer la conexión realice la carga de el firmware grbl a mi arduino uno, probé con Universal Gcodesender, grb controller y cnc control, realice los ajustes de pasos y velocidad para que funcionen los motores y todo bien excepto que el eje X se queda bloqueado y solo suena mientras dure el pulso y después se calla y se vuelve suave, después de esto me puse a meditar sobre algún fallo que pude haber tenido y revise todo paso por paso inclusive cambie los drivers de posición y los motores lo cual hace que funcione en el lugar cambiado pero en el eje X nada, también cambie a otro arduino uno tal vez era el problema pero tampoco, probé con versiones diferentes del GRBL (7,8 y 9) y no tuve resultados.
También probé con clonar el cuarto driver y si se puede en los ejes Y y Z pero en el X no pasa nada
No encuentro la falla y no se si alguien tuvo el mismo problema y me pueda dar una manito con el tema, les agradesco todos los datos que me puedan brindar.




Moderador:Lee las normas del foro
1. Titulo mal porque escribiste Ayuda.
2. Enlaces sin etiqueta.
3. Imagen no visible.


_jose_

#1
Apr 17, 2019, 11:53 am Last Edit: Apr 17, 2019, 11:57 am by _jose_
De lo que comentas ,lo unico que no has cambiado es la propia shield cnc ,por lo que el problema podria ser las pistas o conexiones del driver x .Quiza podrias probar cambiar el mapeo de pines de grbl para usar el zocalo de  clonacion de  eje como zocalo x.Tendrias que averiguar a que pines estan conectados el step y dir de dicho zocalo y cambiarlos por los que hay en el x en el fichero grbl/cpu_map/cpu_map_atmega328p.h.Hazte una copia de seguridad de todo lo que cambies para poder volver al punto de partida si no funciona.

Go Up