Go Down

Topic: Mac Mojave will not detect Pro Mini 3.3v via FTDI Programmer (Read 139 times) previous topic - next topic


I'm at my wits end here. I have read every single topic on this forum, on StackExchange, and on the Mac forums with no resolution. I've always had issues programming Pro Mini units on my 2017 Macbook Pro (USB-C only) but typically I could unplug the unit a few times and eventually the Mac/IDE would pick it up as something being on the port. Now it will not detect it at all. It doesn't matter how many times I reboot, remove the drivers, reinstall the drivers (third-party or official FTDI drivers), or try any other combination of solutions proposed out there.

I have zero issues detecting anything else on my USB ports except for Arduino units. It doesn't matter if they are clones or originals, none were detected reliably and now none of them are detected at all.

Do any of you have suggestions on how to address this besides the following (all of which have been tried multiple times now):
  • - Changing USB cables
  • - Removing/reinstalling drivers (originals or third party)
  • - Using third-party serial detection software
  • - Endlessly unplugging/replugging the Arduino
  • - Endlessly rebooting

There has to be a reliable solution to this problem given all the people using newer Mac OS's. Most of the posts I see online are usually people regurgitating the same suggestions, none of which have worked. I never had this issue before Mojave and moving back to High Sierra is not a possibility. Any help is appreciated, this is getting incredibly frustrating.


Did the problem start immediately after you updated to Mojave?

Go Up