Go Down

Topic: Can't upload to feather M0 adalogger (Read 168 times) previous topic - next topic

joey_jo_jo_5

Hello all,
Ive tried multiple times to upload a simple blink to the feather M0 adalogger. Im on the second board and get the same results. Below is the verbose output.

Sketch uses 9544 bytes (3%) of program storage space. Maximum is 262144 bytes.
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {COM19, } => {}
PORTS {COM19, } / {} => {}
PORTS {} / {} => {}
PORTS {} / {COM19, } => {COM19, }
Found upload port: COM19
C:\Users\Tom\AppData\Local\Arduino15\packages\arduino\tools\bossac\1.7.0/bossac.exe -i -d --port=COM19 -U true -i -e -w -v C:\Users\Tom\AppData\Local\Temp\arduino_build_644567/Blink.ino.bin -R
Set binary mode
readWord(addr=0)=0x20007ffc
readWord(addr=0xe000ed00)=0x410cc601
readWord(addr=0x41002018)=0x10010305
version()=v2.0 [Arduino:XYZ] Mar  5 2016 17:46:52
chipId=0x10010005
Connected at 921600 baud
readWord(addr=0)=0x20007ffc
readWord(addr=0xe000ed00)=0x410cc601
readWord(addr=0x41002018)=0x10010305
Atmel SMART device 0x10010005 found
write(addr=0x20004000,size=0x34)
writeWord(addr=0x20004030,value=0x10)
writeWord(addr=0x20004020,value=0x20008000)
Device       : ATSAMD21G18A
readWord(addr=0)=0x20007ffc
readWord(addr=0xe000ed00)=0x410cc601
readWord(addr=0x41002018)=0x10010305
Chip ID      : 10010005
version()=v2.0 [Arduino:XYZ] Mar  5 2016 17:46:52
Version      : v2.0 [Arduino:XYZ] Mar  5 2016 17:46:52
Address      : 8192
Pages        : 3968
Page Size    : 64 bytes
Total Size   : 248KB
Planes       : 1
Lock Regions : 16
Locked       : readWord(addr=0x41004020)=0xffff
readWord(addr=0x41004020)=0xffff
readWord(addr=0x41004020)=0xffff
readWord(addr=0x41004020)=0xffff
readWord(addr=0x41004020)=0xffff
readWord(addr=0x41004020)=0xffff
readWord(addr=0x41004020)=0xffff
readWord(addr=0x41004020)=0xffff
readWord(addr=0x41004020)=0xffff
readWord(addr=0x41004020)=0xffff
readWord(addr=0x41004020)=0xffff
readWord(addr=0x41004020)=0xffff
readWord(addr=0x41004020)=0xffff
readWord(addr=0x41004020)=0xffff
readWord(addr=0x41004020)=0xffff
readWord(addr=0x41004020)=0xffff
none
readWord(addr=0x41004018)=0
Security     : false
Boot Flash   : true
readWord(addr=0x40000834)=0x7000a
BOD          : true
readWord(addr=0x40000834)=0x7000a
BOR          : true
Arduino      : FAST_CHIP_ERASE
Arduino      : FAST_MULTI_PAGE_WRITE
Arduino      : CAN_CHECKSUM_MEMORY_BUFFER
Erase flash
chipErase(addr=0x2000)
done in 0.826 seconds

Write 9800 bytes to flash (154 pages)
write(addr=0x20005000,size=0x1000)
writeBuffer(scr_addr=0x20005000, dst_addr=0x2000, size=0x1000)

SAM-BA operation failed
An error occurred while uploading the sketch

[============                  ] 41% (64/154 pages)write(addr=0x20005000,size=0x1000)
writeBuffer(scr_addr=0x20005000, dst_addr=0x3000, size=0x1000)

[========================      ] 83% (128/154 pages)write(addr=0x20005000,size=0x680)
writeBuffer(scr_addr=0x20005000, dst_addr=0x4000, size=0x680)

[==============================] 100% (154/154 pages)
done in 0.062 seconds

Verify 9800 bytes of flash with checksum.
checksumBuffer(start_addr=0x2000, size=0x1000) = 9b9
checksumBuffer(start_addr=0x3000, size=0x1000) = 3501
checksumBuffer(start_addr=0x4000, size=0x648) = f587
Verify successful
done in 0.014 seconds
CPU reset.
readWord(addr=0)=0x20007ffc
readWord(addr=0xe000ed00)=0x410cc601
readWord(addr=0x41002018)=0x10010305
writeWord(addr=0xe000ed0c,value=0x5fa0004)




Things I have checked/tried:
-Cable is good
-tried manually uploading
- tried using older board libraries from board manager
- USB 2.0 and 3.0 ports

I am using IDE 1.8.8 on Windows 7.

Any help would be appreciated!  Thank You!

spycatcher2k

Quote
Things I have checked/tried:
-Cable is good
-tried manually uploading
- tried using older board libraries from board manager
- USB 2.0 and 3.0 ports
Have you tried contacting Adafruit about their NON ARDUINO board?
Mrs Drew
-=-
http://www.uk-pcb.co.uk - UK PCB Fab Company
I will design & code for you, but I will also charge you (PM me)
If you don't like my answers, realize : I'm not being cheeky, I'm Just trying to prompt you to use your own brain/google etc.

pert

Are you certain the upload failed? From the output you posted, that looks like a successful upload. The Arduino IDE will show an orange bar with an error message if the upload failed. If it shows a teal bar with the message "Done uploading", then you know it successfully uploaded.

If the upload was successful but the LED is not blinking, that is a completely different issue.

joey_jo_jo_5

It displays an orange bar with "Error occured during upload". I forgot this is not an arduino board.  will take the issue to adafruits site.  Thanks pert.

Go Up