Go Down

Topic: Will not upload to Nano (Read 454 times) previous topic - next topic

rickir206

For some reason, my IDE has stopped uploading code to my Arduino Nano (on COM3).  The error message is:" arvdude: stk500-getsync() attempt 1 of 10: not in sync: resp 0x00".  I get this 9 more times then the message: "an error occurred while uploading the sketch". It appears the my laptop/IDE cannot get in sync to data transfer with the Nano. 

I have tried (1) going through the Arduino/en/Guide/troubleshooting#upload… good material, but not helpful in this case  (2) re-booting my laptop and resetting the Nano. (3) trying a different cable and (4) unplugging everything and plugging it back in. This is about the extent of my ability to solve this type of problem. 

My Windows 10 task manager says USB serial CH340 (COM3) is working properly.  My system has been working correctly until yesterday.


Any suggestions you have for a solution will be greatly appreciated.


rickir206

spycatcher2k

Choose 328 old bootloader from the boards / chip menu and retry, report back.
Mrs Drew
-=-
http://www.uk-pcb.co.uk - UK PCB Fab Company
I will design & code for you, but I will also charge you (PM me)
If you don't like my answers, realize : I'm not being cheeky, I'm Just trying to prompt you to use your own brain/google etc.

For some reason, my IDE has stopped uploading code to my Arduino Nano (on COM3).  The error message is:" arvdude: stk500-getsync() attempt 1 of 10: not in sync: resp 0x00".  I get this 9 more times then the message: "an error occurred while uploading the sketch". It appears the my laptop/IDE cannot get in sync to data transfer with the Nano. 

I have tried (1) going through the Arduino/en/Guide/troubleshooting#upload… good material, but not helpful in this case  (2) re-booting my laptop and resetting the Nano. (3) trying a different cable and (4) unplugging everything and plugging it back in. This is about the extent of my ability to solve this type of problem. 

My Windows 10 task manager says USB serial CH340 (COM3) is working properly.  My system has been working correctly until yesterday.


Any suggestions you have for a solution will be greatly appreciated.


rickir206

Friend, good afternoon. Try to pass the code selecting the board dueminalove.
Esp. Sandro Mesquita
Industrial Mecatronic in Institute Federal of Ceará
Specialist in Engineer of Petroleum
Specialist in Industrial Automotation

DrAzzy

Choose 328 old bootloader from the boards / chip menu and retry, report back.
This could only be the solution if you were previously using an older version of the AVR board package and used board manager to upgrade it between when it last worked and now, or upgraded the IDE entirely. If this is the case, shame on you for not mentioning that you just did a big upgrade.
ATTinyCore for x4/x5/x61/x7/x8/x41/1634/828/x313 megaTinyCore for the megaavr ATtinies - Board Manager:
http://drazzy.com/package_drazzy.com_index.json
ATtiny breakouts, mosfets, awesome prototyping board in my store http://tindie.com/stores/DrAzzy

Esp. Sandro Mesquita
Industrial Mecatronic in Institute Federal of Ceará
Specialist in Engineer of Petroleum
Specialist in Industrial Automotation

rickir206

Thank you all.  A solution has been found!

I tried "spycatcher2k" 's advice and got the error message "scr open(): can't open device "\\.\com3": the system cannot find the specified file."  I next tried Sandro's suggestion and got the same error message...but the OS assigned a new COM port (6) to the board.  So, I next tried: Nano on COM6 with the old boot loader and it works.  DrAzzy is correct that I recently upgraded to IDE 1.8.9 and did not mention it.  Shame on me.


ricki206

Esp. Sandro Mesquita
Industrial Mecatronic in Institute Federal of Ceará
Specialist in Engineer of Petroleum
Specialist in Industrial Automotation

JB47

Hi there.

I have exactly the same problem as Rickir206....including the error messages. It has been driving me crazy over the past 24 hrs, untill I realized the Pro Mini is a retired board which could be the problem. So, looking for a solution I hit upon this discussion quickly.
I would like to use the suggested solution, but where do I find "the old bootloader" in the IDE? I also have IDE 1.8.9.
Thanks for helping out!

pert

I realized the Pro Mini is a retired board which could be the problem.
No. That's not it. The Pro Mini still works just as well as ever.

where do I find "the old bootloader" in the IDE?
That option is only available for the Nano board. The Pro Mini doesn't have an old bootloader because it doesn't have a new bootloader. It's all just the same bootloader it's always had.

There are 16 MHz and 8 MHz Pro Minis. Make sure you have the right Tools > Processor menu setting selected for your Pro Mini.

rickir206

Several monitors (spycatcher2k, SandroMesquita, and DrAzzy (my thanks to all))  replied to my post.  A combination of their suggestions worked for me. This is what worked: (1) I tred uploading with "dueinalove" selected as the board.  This does not make it work, but the system assigned a new COM port number to the board (COM6 in my case). I went back and change the board back to a Nano.  Now had the Nano on Com6 rather than the non-working COM3.  I then went to boards/chip menu and selected from bootloader "Arduino 328 (old)"  (or something like that, I don't have it in front of me right now).  With the Nano on a new COM port and the old bootloader, everything works great.  Note: for all I know, it might work with the newer bootloader also...I just didn't try it.  Hopes this helps.  rickir206

JB47

Hi Rickir206!
Thanks for your summary; just tried to upload the sketch using "Uno" instead of the pro mini, since the chip is an AT328. That did change the com port and gave NO error message(!). Then I switched back to the pro mini setting in "boards" and tried the upload once more....................ERROR.
So, it looked like I can upload using the Uno setting.
Did the test with an alternative of the Blink example and sure enough, it works! (as an Uno, that is!)
Thanks all for your help!

pert

So, it looked like I can upload using the Uno setting.
Interesting. Where did you get this Pro Mini from? Did you ever do a "Burn Bootloader" on it?

spycatcher2k

For the pro mini, did you choose the correct speed from the processor menu?
Mrs Drew
-=-
http://www.uk-pcb.co.uk - UK PCB Fab Company
I will design & code for you, but I will also charge you (PM me)
If you don't like my answers, realize : I'm not being cheeky, I'm Just trying to prompt you to use your own brain/google etc.

Several monitors (spycatcher2k, SandroMesquita, and DrAzzy (my thanks to all))  replied to my post.  A combination of their suggestions worked for me. This is what worked: (1) I tred uploading with "dueinalove" selected as the board.  This does not make it work, but the system assigned a new COM port number to the board (COM6 in my case). I went back and change the board back to a Nano.  Now had the Nano on Com6 rather than the non-working COM3.  I then went to boards/chip menu and selected from bootloader "Arduino 328 (old)"  (or something like that, I don't have it in front of me right now).  With the Nano on a new COM port and the old bootloader, everything works great.  Note: for all I know, it might work with the newer bootloader also...I just didn't try it.  Hopes this helps.  rickir206
Congratulations, and thankyou for to share the solution.
Esp. Sandro Mesquita
Industrial Mecatronic in Institute Federal of Ceará
Specialist in Engineer of Petroleum
Specialist in Industrial Automotation

Go Up