Go Down

Topic: ESP8266 (ESP 01) module Flash & AT commands (Read 1 time) previous topic - next topic

Kishor_ino

Code: [Select]
Hello,

i am interfacing ESP 01 with Arduino Mega 2560.
There i first tried checking AT commands but i don't get any response from ESP 01  wifi module.
Hence using youtube video i tried Flashin ESP 01 for GPIO 1 Toggling i.e. LED blonling code with proper board & baud rate selection.

it's not done , it shows following error message.
please suggest what to do???



[codeArduino: 1.8.8 (Windows 7), Board: "Generic ESP8266 Module, 80 MHz, Flash, Disabled, All SSL ciphers (most compatible), ck, 26 MHz, 40MHz, DOUT (compatible), 512K (no SPIFFS), 2, nonos-sdk 2.2.1 (legacy), v2 Lower Memory, Disabled, None, Only Sketch, 115200"

Sketch uses 257696 bytes (51%) of program storage space. Maximum is 499696 bytes.
Global variables use 26572 bytes (32%) of dynamic memory, leaving 55348 bytes for local variables. Maximum is 81920 bytes.
esptool.py v2.6
2.6
esptool.py v2.6
Serial port COM15
Connecting........_____....._____....._____....._____....._____....._____.....____Traceback (most recent call last):
  File "C:\Users\user\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.5.1/tools/upload.py", line 25, in <module>
    esptool.main(fakeargs)
  File "C:/Users/user/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/2.5.1/tools/esptool\esptool.py", line 2653, in main
    esp.connect(args.before)
  File "C:/Users/user/AppData/Local/Arduino15/packages/esp8266/hardware/esp8266/2.5.1/tools/esptool\esptool.py", line 468, in connect
    raise FatalError('Failed to connect to %s: %s' % (self.CHIP_NAME, last_error))
esptool.FatalError: Failed to connect to ESP8266: Timed out waiting for packet header
esptool.FatalError: Failed to connect to ESP8266: Timed out waiting for packet header

_

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.
]


regards,
kishor.

Kishor_ino

i refer this on youtube:   How to Program #esp8266 using Arduino uno.

link:   https://www.youtube.com/watch?v=N5MoXarCF_4

Kishor_ino

hi,

after searching more deep...
i found one post similar to my issue.

there i simply put arduino in reset state while flashing ESP8266. (other settings as set earlier as in referred video.)

& it' done.

thanks to them. :)  :)  :)

Go Up