Go Down

Topic: Sensore GSM, consigli degli acquisti (Read 370 times) previous topic - next topic

Progressify

Ciao ragazzi
Alla fine sono riuscito a farli funzionare..

Praticamente se provavo ad alimentare i GSM "normali" (cioè senza mettere il super condensatore) con più di 5v ricevevo un errore quando inviavo i comandi AT, era un messaggio del tipo "over-voltage warning". Quelli con il condensatore potenziato invece anche a 5.9v andavano bene, nessun warning.

Però comunque non mi funzionavano continuativo a ricevere un "no dialtone" oppure "no carrier".. ed è stato proprio questo no carrier a farmi pensare che probabilmente non riusciva ad agganciare il segnale automaticamente. Ho cercato un comando AT che servisse ad agganciare la linea, se ricordo bene at+creg (ma non ne sono sicurissimo, vi darò conferma) ed ha agganciato il segnale ed ha iniziato a funzionare bene ...

Ora la mia domanda è... Ma è normale questa cosa? Non dovrebbe agganciare da solo il segnale del proprio operatore? Se sapete qualcosa illuminatemi

Grazie a tutti

zoomx

Ho usato modem GSM tanti anni fa ma mi par di ricordare perfettamente che l'aggancio alla rete fosse automatico, proprio come i cellulari e gli smartphone.
Però può essere che ci sia qualche settaggio per evitare l'aggancio automatico che è stato usato nei tuoi moduli.


docdoc

Alla fine sono riuscito a farli funzionare..
Praticamente se provavo ad alimentare i GSM "normali" (cioè senza mettere il super condensatore) con più di 5v ricevevo un errore quando inviavo i comandi AT, era un messaggio del tipo "over-voltage warning". Quelli con il condensatore potenziato invece anche a 5.9v andavano bene, nessun warning.
Mah, meglio così se hai (in parte) risolto, ma a me continua a sembrare molto strana questa cosa... Il SIM800L funziona a quei livelli indicati nel datasheet, quindi non ci sono santi. Se lo alimenti con più di 5V (più "quanto"? 5.5V? 6V?...) e ti dà quell'over-voltage significa che al SIM arrivano più del massimo che supporta (4.4V mi pare). Per cui o i due diodi (in alcune versioni, comrpesa la tua credo, si trovano uno sopra ed uno sotto, dove c'è la SIM) sono in corto e fanno passare i 5V, oppure non mi spiego la cosa.



Alex "docdoc" - ** se ti sono stato d'aiuto, un punto karma sarà gradito, clicca su "add" qui a sinistra, vicino al mio nome ;) **

Go Up