Go Down

Topic: Cannot upload sketches after changing baud rate (Read 761 times) previous topic - next topic

tar_get

hey guys,

i am realtively new to the usage of arduino.

i have an arduino MEGA (atmega2560) and i tried to test an RFID shield.
for this reason i had to change the baud rate of the serial monitor.

after this i could no longer upload any sketch.
i am using linux (fedora 15) at 32bit and 64bit. so it was no matter of the computer i tried to flash the sketch.

the compiler/avr dude says:

Code: [Select]

processing.app.SerialNotFoundException: Serial port '/dev/ttyACM2' not found.  Did you select the right one from the Tools > Serial Port menu?
at processing.app.Serial.<init>(Serial.java:153)
at processing.app.Serial.<init>(Serial.java:76)
at processing.app.debug.Uploader.flushSerialBuffer(Uploader.java:75)
at processing.app.debug.AvrdudeUploader.uploadViaBootloader(AvrdudeUploader.java:93)
at processing.app.debug.AvrdudeUploader.uploadUsingPreferences(AvrdudeUploader.java:56)
at processing.app.Sketch.upload(Sketch.java:1603)
at processing.app.Sketch.exportApplet(Sketch.java:1568)
at processing.app.Sketch.exportApplet(Sketch.java:1524)
at processing.app.Editor$DefaultExportHandler.run(Editor.java:2320)
at java.lang.Thread.run(Thread.java:679)



i had some problems with finding the USB-port but after unpluging the arduino and restarting the arduino IDE it worked, until now.

i have already read something about an equivalent problem but it did not help
at all. so i am asking you for help.

thanks for your help!

tar_get

Go Up