Go Down

Topic: DS1307 doesn't work, broken? (Read 1 time) previous topic - next topic

Blue_Screen

Hello everybody,

some time ago I got an Adafruit DataLogger Shield with a DS1307 RTC and I can't get it to work.
I hope is the the place to post this issue.

I have already done a lot of tests on it. Checking the whole soldering stuff. Testing different Libraries. I have an Arduino MEGA so I can't use the standard library with Wire. Instead I have to use one which implements SoftI2CMaster.
I also checked all the pins of the DS1307, they have correct voltage supply refering to the datasheet.

After all I can't get it to work. How can I figure out if my DS1307 is broken? Or is it a problem with the crystal oscillator?

I hope somebody has an idea on what to do to fix this problem :)

Thanks

nickgammon

My first guess is the SoftI2CMaster library ... or the way you used it.

My suggestion would be to unplug the shield for now and just run jumper wires, sufficient to power up the clock. So that would basically be +5V, Gnd, SDA, SCL. Then plug them into the "real" I2C pins on the Mega, and fire up a small test sketch.
Please post technical questions on the forum, not by personal message. Thanks!

More info: http://www.gammon.com.au/electronics

Blue_Screen

This is my new result.
___________________________________________________________
2012/4/14 9:46:11
since midnight 1/1/1970 = 1334396771s = 15444d
now + 7d + 30s: 2012/4/21 9:46:41

2012/4/14 9:46:12
since midnight 1/1/1970 = 1334396772s = 15444d
now + 7d + 30s: 2012/4/21 9:46:42
__________________________________________________________


I use the ds1307 example from the RTClib library provided by Adafruit.
The seconds count is still way to slow but know it eventually accepts the time at all.

This brings up the next problem. What should I do with the Shield? Having the DS1307 on a Breadboard without Coin cell and board is not the purpose it was meant to be. :)

Thanks for advice

nickgammon

https://www.adafruit.com/products/243

From that page (in bold):

Quote
PLEASE NOTE: This shield is not MEGA compatible at this time


Quote
I have an Arduino MEGA ...


You bought a shield that was not compatible with your Mega. Why did you do that? It isn't broken.
Please post technical questions on the forum, not by personal message. Thanks!

More info: http://www.gammon.com.au/electronics

cmiyc

I think Nick already identified your issue.


some time ago I got an Adafruit DataLogger Shield with a DS1307 RTC and I can't get it to work.
I hope is the the place to post this issue.

One place to ask about Adafruit products might be Adafruit's support forums...
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

Blue_Screen

I guess you're right. To be honest I didn't find the warning "not compatible with MEGA" just after I bought the shield. Probably due to the fact, that I didn't order it directly from Adafruit but another vendor. And that one did not have such a warning on his page.
Nevertheless, I found some advice about it on the Adafruit forums that I could still get this shield running.

http://forums.adafruit.com/viewtopic.php?f=31&t=27245

But obviously this fix doesn't work for me.

At least now I know that the DS1307 isn't broken. :)

Go Up