Go Down

Topic: [Résolu] Arduino IDE sur linux (Read 1 time) previous topic - next topic

zerr0s

Apr 21, 2012, 11:38 am Last Edit: Apr 22, 2012, 08:43 am by zerr0s Reason: 1
Bonjour,

J'ai un souci avec l'IDE arduino sur mon linux. Je n'utilise pas gnome, ni kde. Je tourne sur awesome, un wm très léger.
Lorsque je lance l'IDE, je me retrouve avec un petite fenêtre que je voudrai agrandir (maximiser). Quand je tente de le faire, la fenêtre ne s'agrandit pas.
voici en PJ ce que ça donne.

Auriez-vous une idée ? Il doit me manquer quelque chose, mais quoi ?!!

fdufnews

Jamais eu ce problème mais j'utilise Ubuntu.
Dans ton home il y a un répertoire caché .arduino.
Dans ce répertoire il y a le fichier preferences.txt.
Tu peux l'éditer à la main, il y des paramètres comme la taille de la fenêtre min, max, par défaut, sa position.
Peut être cela pourra-t-il régler ton problème.

Autrement il faudrait regarder du coté de la machine Java que tu utilises. Peut-être y a-t-il une incompatibilité.

zoroastre

#2
Apr 21, 2012, 11:25 pm Last Edit: Apr 21, 2012, 11:30 pm by zoroastre Reason: 1
Yep!

J'utilise awesome également sous Debian Squeeze.

installes le paquet : suckless-tools
(Détail ici : http://awesome.naquadah.org/wiki/Problems_with_Java)

et

ajoutes à la fin de ton rc.lua :

Code: [Select]
awful.util.spawn("/usr/bin/wmname LG3D")

C'est un problème que l'on retrouve sur presque tous les tiling manager.

@+

Zoroastre.
Gné! ;)

zerr0s

Ça me parle de wmname !!! Mais comme ça fait un bail que je n'ai pas touché aux apps java ...

Bon pour le moment peut plus rien faire. Dslam KO chez fr**

Je teste quand la connexion revient. Merci pour la piste.

zoroastre

#4
Apr 22, 2012, 08:28 am Last Edit: Apr 22, 2012, 08:33 am by zoroastre Reason: 1
Yep!

Quote from: zerr0s
comme ça fait un bail que je n'ai pas touché aux apps java


Pas besoin de toucher à une application java particulière.

wmname te permettra de redimentionner à volonté les applications java, en effet, le moteur java n'implémente pas l'option LG3D indispensable pour certain window manager comme ceux à gestion par tuile (tiling manager).

Ce que je te propose n'est pas une piste mais la solution.

Installes le paquet suckless-tools à partir de aptitude ou apt ou de ton gestionnaire de paquets préferé.

et ensuite modifies le fichier de configuration de awesome avec un éditeur de texte quelconque, fichier situé dans ~/.config/awesome/rc.lua en ajoutant à la toute fin :

Quote
awful.util.spawn("/usr/bin/wmname LG3D")


La fonction awful.util.spawn te permet de démarrer une application au démarrage de ton wm. (Vérifies que tu as bien require("awful") en tête du fichier de configuration.)

NOTE : awesome wm est écrit en language LUA.

@+

Zoroastre.
Gné! ;)

zerr0s

Merci pour LA solution :) Je ne tourne pas sur debian mais plutôt sur gentoo. Le paquet existe bien dans les repos.

J'ai fait la manip et c'est impeccable :) Merci encore. Je vais pouvoir continuer mon apprentissage arduino :)

Go Up