Go Down

Topic: serial port problems [SOLVED] (Read 29246 times) previous topic - next topic

donde

Jun 11, 2012, 04:30 am Last Edit: Jun 11, 2012, 05:22 pm by donde Reason: 1
Here is the solution for me in not seeing serial port
Using IDE 1.0.1 on, Mint, or Mint-Deb, or probably Ubuntu:
With board plugged in, try this. sudo sh arduino, then click run in terminal.
You should now see entry in Serial Port. To make it permanent, I did this.
sudo usermod -a -G tty yourUserName
sudo usermod -a -G dialout yourUserName

Now just type arduino in arduino folder, run in terminal. Making a launcher will start IDE
from an icon. Serial Port will be seen. Problem is solved on Linux and Windows 7 boxes!

It was all a matter of permission, typical Linux!
Disregard below.

I'm writing this using an HP tower and Mint-Debian OS.  1.0.1 IDE works fine with both the Uno 1st release and the just received Leonardo. For the both devices. I see /dev/ttyACM0 for serial port. No problem.

Now, here is what's strange. Now not so strange!
I have an Acer netbook dual boot with Mint-Debian and Windows 7 Starter. I put the 1.0.1 IDE on both OS's. On Windows 7, the Uno works OK. I see serial port 3. Trying Leonardo and switching board to Leonardo, Windows 7 tries to find a driver, but can't. So, no serial port. Leonardo is now fixed.

This is still true
Booting Mint-Debian on the netbook, neither of the 2 boards work. Serial port is always greyed out.
Earlier in the week, I had Windows 7 and Ubuntu 12.04 on the netbook. Then, I used IDE 0022, and the Uno worked fine. Didn't have Leonardo yet. I have another box with Mint on it. I'll try it.

As you see, I'm not sure what the problem is, the netbook or the newest IDE or both. Ideas appreciated. Looks more like the OS.

glenndrives

I am still having this problem even though the permissions have been set properly on my Ubuntu 12.04 64bit installation.

When I first start the Arduino IDE after a reboot the serial port is seen by the IDE. I can upload and use the Serial Monitor for debugging. If I try to upload a sketch while the serial monitor is running the IDE quits the Serial Monitor and reports that /dev/ttyACM0 is not found. I have to reboot the computer to get the serial port back.

Even running the IDE with sudo ./arduino does not bring back the serial port.

Thanks for any help you can give.

Go Up