Go Down

Topic: Going crazy with two UART-Adaptors, two Arduino Mini Pro and one Arduino Nano (Read 1 time) previous topic - next topic

clockdivider

Hello girls an d boys...

I am desperatly trying to put some software up to an arduino mini proCannot load software to my Arduino Mini Pro, yet no success.

This is my problem: I bought an arduino mini pro and want to put the "Blink" Patch onto it. I have an UART adaptor. Now when trying to upload the patch, I got an "stk500_getsync() not in sync resp=0x00" error. So I tried another UART adaptor. Same thing. So I treied another Mini Pro. Same message. Now I tried the UART adaptor plugged onto an Arduino Nano 3.0. Both adaptors working perfectly, when connecting + and - and RX/TX only. Thus I am sure both adaptors work. But this would mean that both Minis are broken!?! I cannot believe that.

I am quite experienced with arduinos, I know I have to press reset on my mini, so I have to when connecting the UART-adaptor to the Nano.

Does anyone have an idea, why two working UART adaptors fail to upload software to Arduino Minis, but not to a Nano?

Thanks a lot! Martin...

wanderson


clockdivider

Thanks a lot! I forgot to mention that! Unfortunately I tested this in every possible direction. So no, that´s not the fault. Nevertheless thanks a lot! Martin...


wanderson

Is it possible the nano's are 3.3v and you may have damaged them by powering them from 5V?  Or that they need 3.3v logic on the USB Serial converter?

clockdivider

Thanks once more! Both boards are 5 Volt. But nevertheless your guess was right. Today I received a new Mini Pro, plugged it to one UART and voilá, immediately it worked. Thus I really have two broken Minis here, one absolutely new, the other one used some time ago. One obviously never saw the light, the other one died some time ago for some reason. However, if someone finds this thread while searching a solution, here is my advice: Take into account the almost impossible, too!

Thanks a lot to you all!

Martin....

Go Up