Go Down

Topic: Arduino UNO r3, USB Unresponsive (Read 2657 times) previous topic - next topic

Dengar

I am a new Arduino owner so I apologize for any noob questions. I received a brand new Arduino UNO r3 yesterday. It was working fine and I was able to program the board. I put it away for the night and when I took it out this morning I found that it is unresponsive. When plugging it into the USB port or the wall wart the 'ON' light is illuminated as well as the LED that is wired to pin 13. The last program does not seem to be running. I have attached a picture of the state of my board. Outside from that there is no response from the board.

When I plug it into a USB port it is not recognized by the computer. I've used multiple computers, cables and ports so I know it's not a PC issue. I have used Ubuntu 12.04 to program the board initially. I have tried it on Windows 7 with no success getting it to connect. If I plug a LED between the ground and pin 13 it does not power up the LED. All it does is dim the light on the board. If I insert that same LED between the ground and the 5v pin it illuminates.

It appears as if the board is frozen and won't even talk to my PC. Is there anyway I can somehow reset the board even though it seems to not initialized with the PC and is completely unresponsive?

Thanks for your time in reading.

johnwasser

Send Bitcoin tips to: 1G2qoGwMRXx8az71DVP1E81jShxtbSh5Hp
See who has no social life: https://forum.arduino.cc/index.php?action=stats :)

Dengar

I was able to recompile the dfu-programmer to recognize the the atmega16u2 chip using this form post. http://arduino.cc/forum/index.php?topic=92148.0.

Following along with this same post someone stated that for the UNO rev 3 since it had a stronger RESET circuit they were able to get it into dfu mode by:

Quote
Briefly connecting ground and reset on the ISP header works for me. I connect them for about one second.


Does this mean that on my UNO I don't need to solder on the 10k resistor that the link in the previous post specifies? Also I assume that the RESET and GROUND pin that are referenced are the ones in this picture. http://arduino.cc/en/uploads/Hacking/Uno-front-DFU-reset.png

What I tried so far was to plug in my Arduino. I touch the two pins that I have pictured above together for a second and I see no change on the board (The ON led and the pin 13 LED stay illuminated and don't blink). I then try to erase the board and get the following output:

Code: [Select]
user@testpc:~$ sudo dfu-programmer atmega16u2 erase
dfu-programmer: no device present.


I assume that I get this output because the board is not in the dfu state. Is what I am doing so far correct in trying to reprogram my atmega16u2 chipset?

Go Up