Go Down

Topic: Restore Bootloader on Mega 2560 (Read 6268 times) previous topic - next topic

Kampfwurst

How can I restore the Bootloader on my Arduino Mega Board. With the Arduino Software I get the error avrdude: stk500_getsync(): not in sync: resp=0x00 when I try to Install the Bootloader with a ISP Programmer.

I tried the ISP Connection next to the reset button.Is this correct. Is there maybe a hex File with I can upload with the AVR Studio 4.18 or 5.1??

Chris

Kampfwurst

when I trie to Upload a Programm over the USB Port I get this error. I tried the Blink programm and my own programm with my flash tool.

stk500_getsync(): not in sync: resp=0x00

nickgammon

The file should in the Arduino distribution, called I think: stk500boot_v2_mega2560.hex

Quote
I tried the ISP Connection next to the reset button.Is this correct.


Yes, on mine it is between the reset button and the processor chip. If there is another ICSP header near the USB port that is for reprogramming the USB chip.

If you can't get avrdude to work, this post describes a way of uploading the bootloader if you have a spare Uno around:

http://www.gammon.com.au/forum/?id=11635
Please post technical questions on the forum, not by personal message. Thanks!

More info: http://www.gammon.com.au/electronics

Kampfwurst

#3
Jul 01, 2012, 11:46 am Last Edit: Jul 01, 2012, 01:56 pm by Kampfwurst Reason: 1
thanks. Now It works nearly perfect. ;-) Only one problem is left.
Before I can flash with my program I have to press the reset button. Is there a way to do this automaticaly?
And is there a special version of the avrdude for the Arduino to flash the hex files?

Go Up