Go Down

Topic: USB serial port not showing on Mac (Read 46840 times) previous topic - next topic


I have an Arduino UNO that I connected to my Macbook Air via the provided USB cable. It worked for a few days but out of nowhere I started getting an error and the usb serial port that i had been using was no longer showing in the tools menu.  Please help me 


No answers so try this while you wait

Try opening a serial monitor on any port that is showing and that might give you a clue as to whats happening on each port.  You dont need a program in the IDE just hit the Serial Monitor button.

Plug the Arduino into another USB port and see what changes in available ports


Got a new mac with a USB 3 port and having difficulties?

I spent hours trying to work out why avrdude threw unusual errors and the Arduino software failed to burn ATtiny 85s, 2313s etc.

It all turned out to be the USB port. Simply connecting a USB 2 hub between the Mac (in my case an Air) and the USBTiny Programmer or Arduino fixed the problem straight away.

Hope this helps someone.


I have a 2012 Macbook Air and I couldn't see a serial port either. My solution was to go here and download updated drivers:
After I installed the new drivers, I could see a serial port in the IDE and everything works as expected.


I have similar problems with my Retina Mac (OS X 10.8): I cant get the USBTinyISP recognized by the system - the power LED stays off. I bought a USB HUB but that did not work. I also tried the above mentioned driver but no luck either.
Any other suggestions?




I spent a few hours going round in circles with this issue, I finally found out the cause. It was the USB cable, the one I was using was designed only to provide power, not to transfer data :(

Changed my USB cable and hey-presto, all was well!

So maybe try a different cable.


Same problem here. Solution.....  for me on a 2011 Macbook Air

1. Disk Utility, repair permissions.
2. Reset the PRAM. Shut down. press Command + Option+ P+ R then the Power Button. Hold down these buttons till the computer restarts the second time, then release.
3. For RFduino will need Arduino 1.5.6 to run. Consider the 1.5.7 Beta.
4. Install/Re-Install the FTDI software.

After this my RFduino serial port showed up and now back to programming. I had been programming on this Macbook previously  and had been away from it for awhile. After the above was able to take this computer on the road again and do some software testing etc.

Best of Luck!!!


Holy crap! I can't believe a change to a different USB cable fixed the problem! USB ugghhhh!

This gave me 4 hours of grief in total. Messing around with serial code then reading about SMC, PRAM, changing ports, plugging in other devices, deleting drivers, reinstalling drivers....

JUST CHANGE CABLES - I guess not all USB cables are made equal.

Go Up