Go Down

Topic: Arduino Leonardo bricks when using tone (Read 2667 times) previous topic - next topic

migus

HI,

I tried to do the tone's example, using tone (8,440,20). Didn't have anything connected to the board. Arduino Leonardo stops responding or executing (I have a routine doing the board's led blinking and it doesn't work when it ahappens). From this moment was unable to transfer anything to Arduino, th COM appears and disapears but the IDE can't upload anything (Windows XP).

The IDE error message is that COM port is already in use (but is not).

Then I tried the board in a Windows 7 and doesn't work anymore.

I mannage to fix it doing the reset trick when sending and with the tone instruction commented. Then I send again the tone instruction and bricks again.

Can anyone with Leonardo try tone (8,440,20) or is just mine?

I'm going a try with a different port ....

Thanks
migus


mulada

I had the same problem with my Leonardo when I tried the Melody example code, and I found references to it in other forums. For me, the only way I could reset the board was to load the EEPROM Clear example sketch. I couldn't get any other code to load. Doesn't make sense to me either - probably user error. Anyway, the fix that is linked above did solve the issue for me. With a minor sketch modification the board is now playing scales through an 8ohm radio shack speaker via a 100ohm resistor on pin 8 as depicted in the tutorial.

migus

The problem I found with the patch is that IDE reports errors some lines before the real line where is the error and is annoying.

Pencilbroker

I got the same problem , when trying to use tone , arduino freezes cant execute  and must reset the code .
Is there a fix for that ? Because i really want to be able to play tone on it .

Go Up