Go Down

Topic: Another avrdude: stk500_getsync(): not in sync: resp=0x00 (Read 6887 times) previous topic - next topic


recently I bought my first Arduino. It arrived at my home two days ago, and since then I've been looking nonstop for the cause of this error.
What happens:

  • I connected the arduino to my computer through the usb cable.

  • The drivers were installed automatically.

  • L13 started to blink fast.

  • PWR is on.

  • I started the Arduino ide and opened blink program.

  • I selected port to COM3

  • I selected board to Arduino Duemilanove w/ ATMega328

  • And clicked upload.

  • The "Binary sketch size: 1.084 bytes (of a 30.720 byte maximum)" appeared and L13 stopped.

  • Leds RX and TX blinked 3 times.

  • Pause of about 10 seconds where nothing happened.

  • L13 blinkes 1 time, stopped and then restarted to blink really fast, as if nothing had happened.

  • The message avrdude: stk500_getsync(): not in sync: resp=0x00 appeared.

I have tried:

  • Changing COM port to 9

  • Pressing reset button before clicking upload

  • Pressing reset button after the "Binary sketch " message

  • Holding reset button until the "Binary sketch " message then releasing

  • Re installing the drivers using those provided with the arduino1 folder.

  • The loopback test passes

Any help??? I'm getting really frustrated here _ _"



do a shift+upload, and write is the arduino original or ebay, and the exact model..


I would guess the Windows driver is not installed. Can you open your device manager and verify the FTDI USB serial driver? Write back and let me know; I'll monitor this thread.


If you are labeled correct, you are going Rx->Rx/Tx->Tx and it is not the "BAITE" board, you will need to cross the connections Rx->Tx and Tx->Rx.  When you upload, you will need to hold the reset and wait till the Tx on the USB2TTL board Tx LED Flashes 2x.  You might want to test with the UNO Optiboot and the Duemilanove 328 boards in the Arduino IDE.

Later, you might want to hook up a 0.1uF cap to Atmega pin1 and your USB2TTL RST (DTR?).

I don't understand what does it mean "you are going Rx->Rx/Tx->Tx and it is not the "BAITE" board, you will need to cross the connections Rx->Tx and Tx->Rx." Could you explain?? And what is the BAITE board?

I would guess the Windows driver is not installed. Can you open your device manager and verify the FTDI USB serial driver? Write back and let me know; I'll monitor this thread.

Do you mean the driver of COM port? It says the device is working properly.

Also, I bought the board from DX.com, and it's not an original. However, its printed in the board "Arduino Duemilanove" and in the chip ATMEGA328P-PU.


Easy way to check the serial port is using the loopback test described at


Let  me know what you find



As said in the first post, I've done it, and it passes.


Indeed you have. Sorry I missed that.

So the driver and USB hardware seems ok; if I'm not mistaken, that turns suspicion on the microcontroller, bootloader, and avrdude.

Easiest way to check avrdude would be to test your computer with another Arduino Duemilanove. If you're in a big city there is a good chance someone around you has an Arduino; you might also try a local hacker space, robot club, or dorkbot chapter.

The microcontroller and bootloader is a little tricker. If you have another Arduino, you might try using the good one to re-burn the bootloader on the troublesome one.

I don't use Windows so I'm making educated guesses here.

Finally, have you asked DX.com? Do they have a forum or mailing list?


I have posted at dx.com, but as it's just a shopping site, the chance of getting a usefull response is small. Anyway, I'll try to contact them. Maybe they will replace it, and then I can test if it's my computer. Or maybe next time I'll buy an original Arduino...

Thank you very much for your time. =]


True, for the few dollars savings I would recommend buying from one of the reputable Arduino or Arduino compatible manufacturers.

Still, I am curious and would like to solve if possible.

If dx.com is just shopping, who manufactured the device? do they have a website? schematics? drivers? a close look at their site might shed some light.

Are you located near any other Arduino enthusiasts, that you might try your Arduino on another's computer, or their Arduino on your computer?


Aug 13, 2012, 03:08 pm Last Edit: Aug 13, 2012, 03:53 pm by elithin Reason: 1
I'm not sure who is the manufacturer. The board is this one:

I don't know anyone who might have an arduino but I have another computer where I can try it on. I'll do it and then post back here.

Edit: I tried it on my laptop and it gave the same error.

Louis Davis

Try selecting a different board type, such as UNO.

When selecting the board type, you are really selecting the type of bootloader that is on the Atmega.

They may have started using the UNO bootloader on the newer boards.

It's worth a shot.


Right, I forgot to mention it on the first post, I've tried selecting almost all boards on the list, and nothing...
Thanks anyway


I solved it!!!!!! Just downloaded the arduino0023 software instead of the 1.0 and it worked like a charm!!!
(Still don't know why the newest doesn't work though)


Congratulations! I don't know well enough the differences between 0023 and 1.0 to be able to explain this, but I'm glad you found a solution.


Having had the same problem recently. Although, mine was mainly caused by the com port being reassigned somewhere along the way.

To help with the arduino program differences.

023 has some older routines and calls.
1.1 runs I think newsoftseriel (or I have this the other way around) as a driver off the top of my head and a few others, that can get in the way of handling certain calls within the program.

perhaps search around for the updated version of your program which calls the new routines.

Go Up