Go Down

Topic: [MOD] Arduino Enhanced Release 1.0.5 for Windows (installer, drivers, etc) +SRC (Read 601580 times) previous topic - next topic



Thanks so much for taking my suggestion in consideration. I really, and I mean REALLY admire your work and I am grateful for it.

Some of my projects:
Shield for DS1337+, DS1624 and AT24C1024B (RTC, temp & mem): http://forum.arduino.cc/index.php/topic,126197.0.html
CHDK Camera remote shutter (BT, IR, USB): http://forum.arduino.cc/index.php?topic=295377.0



There are 21 pages of stuff.

I just quickly downloaded the file, installed the .Net 4 stuff and tried.

Real useful popup just happened.

"An error ocurred while starting the application."



There are 21 pages of stuff.

My heart bleeds for you. It really does.

Are you sitting comfortably? Then I shall read it all to you...

WiFi shields/Yun too expensive? Embeddedcoolness.com is now selling the RFXduino nRF24L01+ <-> TCP/IP Linux gateway: Simpler, more affordable, and even more powerful wireless Internet connectivity for *all* your Arduino projects! (nRF24L01+ shield and dev board kits available too.)


That would nearly constitute Australian humour.

I am having no end of trouble getting the sketches to flash and am just giving it a go.

I was hoping for a quick and easy set up so I can find out what is going on.

If it can't load, for now it is wasting my time.

Yes, what I posted wasn't exactly nice.

But so much for people helping each other.


Can you capture the screen with the error? does it pops after the installation? Can you describe your machine? Windows version, what happens with the official one that drove you to try this mod, etc
My website: http://ried.cl


Yes, the error is after installation.

Before I did it, I got/downloaded .Net 4 and installed it.
(Fun - NOT!)

Then installed the IDE.

This is the error:

(Cropped screen grab)


Are you launching the IDE from the start menu? or launching the previous version?

What version did you installed? the FULL or the one that says no-java ?

I know installing .Net is not fun, but it is usually already installed by Windows Update and it makes the development of certain enhancements much easier.
My website: http://ried.cl


Well, I have 1.0.1 and 1.0.2 installed.

These are the "official" versions.

Then I tried yours.

I also have that "Maria Mole" installed.

As this one comes as a .exe I ran the install and let it do its thing.
It starts to load then simply puts that message on the screen.

The IDE is being launched from a shortcut - which it generated.
The version is the one at the start of this thread - which says no java.


Download the first link, the package should be 35 mb or so. That one will solve your problem.
My website: http://ried.cl


You mean this one:


That is the one I have.
(That is the first link I can find.)


Yes, the error message is because there is something wrong with java. The other thing you can try is installing java, and downloading the version without java. But your problem is very strange.
My website: http://ried.cl


I just checked and I have the latest Java.

So I hope that is good.

I am downloading the "no-java" version now.

(Cute how they go in program files\arduino\...... rather than just in program files\.....  how I have the other two.)
Took a bit of finding.

Installed the NON-JAVA version.  Same problem.
It just gives up on me.   Same error.
(I put in in a similar path but appended NO JAVA to the end, so I have both versions installed.)

That isn't a problem is it?


No, no issues. There is a last thing to do: http://screencast.com/t/LLlm4QraF

And paste that log here.
My website: http://ried.cl


As requested:

CmdLine:   C:\Program Files\Arduino\Arduino ERW 1.0.3\arduino.exe --l4j-debug
WOW64:      no
Working dir:   C:\Program Files\Arduino\Arduino ERW 1.0.3\.
Bundled JRE:   java
Check launcher:   C:\Program Files\Arduino\Arduino ERW 1.0.3\java\bin\javaw.exe (OK)
Add classpath:   lib\pde.jar
Add classpath:   lib\core.jar
Add classpath:   lib\jna.jar
Add classpath:   lib\ecj.jar
Add classpath:   lib\RXTXcomm.jar
Launcher:   C:\Program Files\Arduino\Arduino ERW 1.0.3\java\bin\javaw.exe
Launcher args:   -Xms256m -Xmx512m -classpath "lib;lib\pde.jar;lib\core.jar;lib\jna.jar;lib\ecj.jar;lib\RXTXcomm.jar" processing.app.Base
Args length:   120/32768 chars


Everything seems right, it is very weird. It should work. Maybe you can track the problem with Process Monitor, looking for locked files that Arduino.exe may fail to load.
My website: http://ried.cl

Go Up