Go Down

Topic: [Résolu] Mon arduino uno semble être KO (Read 1 time) previous topic - next topic

zerr0s

Oct 27, 2012, 12:47 pm Last Edit: Oct 29, 2012, 04:27 pm by zerr0s Reason: 1
Bonjour,

Depuis hier j'essaie d'uploader mes sketchs dans mon arduino uno (première version), et impossible:
Code: [Select]
avrdude: stk500_recv(): programmer is not responding

J'ai cherché sur le forum, sur google, et j'arrive à la conclusion que mon bootloader semble être dans un sale état.
Ce qui me fait dire ça est que partout, les personnes disent arriver à la remettre sur peid grâce au bouton reset.
Or chez moi, la led L ne clignote jamais.

Quand j'envoie un sketch, la led RX clignote, mais rien en TX.

Je suis sur gentoo (linux). Alors j'ai pensé à la brancher sur un windows xp et là je n'ai pas le même message:
Code: [Select]
stk500_getsync(): not in sync

La version de l'ide: 1.0.1

Est-il possible que mon atmega328p-pu soit dans les choux ? Comment est-ce possible ? Est-il possible de la reprogrammer simplement en la connectant sur une breadboard
et un PC ou faut-il un programmateur ?

J'espère que vous pourrez m'aider.

Il y a peut être quelque chose qui peut t'aider ici

désinstalle tout les drivers et réinstalle tout

skywodd

Bonjour,

Quand le programme finit de ce compiler appui sur reset de ton arduino.
Si tout va bien la led pin13 doit clignoter 3 fois.

Ensuite c'est la led Tx (et non Rx) qui devrait clignoter même en cas de problème.
Essaye aussi si possible de faire un upload d'un sketch vide avec un PC sous windows, le délai qu'ajoute windows à l'ouverture d'un port série débloque parfois la situation.
Des news, des tutos et plein de bonnes choses sur http://skyduino.wordpress.com !

zerr0s

Merci pour ces réponses.

J'ai déjà essayé la solution de connecté l'arduino sur un windows et d'uploader un sketch vide, et d'appuyer sur RESET aussitôt que le sketch est envoyé.
Pas d'améliorations.

Pour les drivers, rien n'était installé sur le poste windows ...

Sinon les solutions proposées sur le lien, j'ai déjà essayé avec les différentes board sur l'IDE, sans succès.
Il reste la possibilité de programmer la board à partir d'une autre. J'ai une arduino mini, mais pas encore reçu le FTDI commandé chez sparkfun.
Sinon j'ai un copain qui a une arduino uno rev3. Je vais voir si je peux lui emprunter.

Sinon, j'ai des connecteurs // qui traînent chez moi. j'en aurai bien fait un, mais ... pas de // sur mon pc lol.

Quand le sort s'acharne ...

#4
Oct 27, 2012, 08:10 pm Last Edit: Oct 27, 2012, 08:14 pm by khobz Reason: 1
Essaye de réinstaller les drivers sous windows, j'ai déjà eu le cas.

Sinon peut être que ça te coûtera moins cher en achetant ceci

zerr0s

Juste une question, puis-je renvoyer un bootloader à partir de mon arduino mini ?

Je lis ce tuto: http://www.jlectronique.org/ArduinoISP.htm

Je me demande si je peux envoyer un bootloader uno depuis une mini ?

zerr0s

Ca y est, mon arduino a ressuscité !! J'ai reprogrammé mon atmega à partir de celui de l'uno d'un copain.

top :)

merci pour votre aide.

Go Up