Go Down

Topic: upload code on arduino pro mini 5v 16mhz 168 (Read 2889 times) previous topic - next topic

victorjung

Hi every body, i know it's a commun problem but, until now i didn't find anything to solve it.
i try to upload programms to my aruino pro mini 5v 16mhz atmega 168 through a ch340 usb to serial adapter.
the driver of the adapter seems to be well installed.
but i get the error:
stk500_getsync(): not in sync: resp=0x00
i know that this error can come from quite every thing...
my adapter, has only 3.3v, 5v gnd rx tx output.
i plugged 5v to vcc. gnd to gnd. rx to rx and tx to tx.
i tried manual reset 1000 times, then  i tried to solder an header to the pin 16 directly on the ch340 chip cause it is a rts pin, the i connect the rts to the rst on the arduino.
now when  upload i can clearly see the board reseting. but i still have the error 15 seconds later... and the board blink again every second.
i almost tried anything, but if think about something i could have miss... lets talk about it!
Thanks to any ideas!

johnwasser


my adapter, has only 3.3v, 5v gnd rx tx output.


Many time you have to connect RX to TX and TX to RX.
Send Bitcoin tips to: 1G2qoGwMRXx8az71DVP1E81jShxtbSh5Hp

victorjung

i tried to cross rx and tx but it didn't worked neither...

johnwasser

Could your USB to Serial adapter be set up for RS323 and not TTL Serial?  The logic levels are different and probably inverted.
Send Bitcoin tips to: 1G2qoGwMRXx8az71DVP1E81jShxtbSh5Hp

victorjung

Thanks for yor help ! I m not sure to know if it s can be used as rs323 but the chip ch340 doesn t have any rs323 output so i guess no.

johnwasser


Thanks for yor help ! I m not sure to know if it s can be used as rs323 but the chip ch340 doesn t have any rs323 output so i guess no.


The datasheet I read show the CH340 as having an input that sets it to RS232.

Perhaps it's time to get a different USB-to_Serial adapter.
Send Bitcoin tips to: 1G2qoGwMRXx8az71DVP1E81jShxtbSh5Hp

Go Up