Go Down

Topic: Problem with Ubuntu - Serial not connecting to tty (Read 1 time) previous topic - next topic

shoeblade

It does not look like my board is being linked to the ttyUSB0

[  873.160153] usb 3-2: new full-speed USB device number 6 using uhci_hcd
[  873.345365] usb 3-2: New USB device found, idVendor=0403, idProduct=6001
[  873.345379] usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  873.345390] usb 3-2: Product: FT232R USB UART
[  873.345398] usb 3-2: Manufacturer: FTDI
[  873.345405] usb 3-2: SerialNumber: A9014FVD

There is no mention of linking to tty

Any ideas?

Thanks

shoeblade

Just to update,
I've tried this:
http://pensacola-tech.com/pensacola/2010/06/01/how-to-enable-usb-serial-port-adapter-on-ubuntu-2/
Does not work

I am running ChrUbuntu
http://chromeos-cr48.blogspot.com/2012/04/chrubuntu-1204-now-with-double-bits.html

lestofante

take a look here: http://arduino.cc/playground/Linux/All

probably you just have to set up properly UDEV, let me know
Guida per principianti http://playground.arduino.cc/Italiano/newbie
Unoffical Telegram group https://t.me/genuino

shoeblade

No joy

From what I understand the usbserial module may not be in my kernel.
Any way to test for / enable that?

Thanks

lestofante

really strange FTDI is enabled by default in many distribution.

BTW recompile the kernel is not that hard, and if you have a good pc it takes less than drink an hot tea.

Thre is a voice in the kernel menu that explicit say FTDI driver, under the USB section if i remember right.

take a look at some basic guide for recompiling kernel in your distribution and everything will be clear (just remember to backup! always!)
Guida per principianti http://playground.arduino.cc/Italiano/newbie
Unoffical Telegram group https://t.me/genuino

Go Up