Go Down

Topic: help with programming ATTINY13a (Read 23140 times) previous topic - next topic

gaggenau

first i tried without the bootloader and then with. same result.
other things i tried was updating arduino ide to 1.0.1
reinstall core13 cores

im going to try to reinstall it on another mac that never had the arduino on it.
im not going to give up. programing a attiny13a with the blinky sketch is not rocket science.


guys! thanks for helping me out.

spcomputing

Just an FYI, when you install other versions of Arduino IDE, it creates a new folder and an isolated version with all the aminities of that version but isolated from other versions other than the Documents\Arduino  directoryand the driver for USB2TTL.

Good luck!

strykeroz


@strykeroz - I found the "burn bootloader" isn't necessary with core13 for setting the clockspeed because the high and low fuses come from the boards.txt.  I just select the 128kHz board and upload the sketch (Don't even have to select Upload via Programmer).
nice one.  I defer to your experience on that as I have settled on ATTiny85 as pretty much my weapon of choice ;)
"There is no problem so bad you can't make it worse" - retired astronaut Chris Hadfield

gaggenau

problem solved! thanks for the help!

the solution was to do a fresh install of the IDE and the core on a another mac.

now the biggest problem is to fit the code in to that tiny little memory of the attiny13 i guess thats why the attiny 85 is more popular.


Go Up